2

I'm using a rooted Note 2 GT-N7100 running DR.Ketan Custom ROM v14.

After flashing this ROM today, I'm unable to use Tasker as a Device Administrator. The check box does not get checked when I click it in order to Activate Device Administrator permission to Tasker to perform certain tasks.

Kindly help me find a solution – Thankx in advance!

  • 1
    Do you have any screen dimming/brightness apps installed (Such as Lux)? – bmdixon Nov 19 '14 at 14:33
1

In the file /data/system/device_policies.xml remove everything and add the following lines,

For Lollipop 5.x.x:

<?xml version='1.0' encoding='utf-8' standalone='yes' ?>
<policies setup-complete="true">
<admin name="net.dinglisch.android.taskerm/net.dinglisch.android.taskerm.MyDeviceAdminReceiver">
<policies flags="8" />
</admin>
</policies>

For Android 4.2.1:

<?xml version='1.0' encoding='utf-8' standalone='yes' ?>
<policies>
<admin name="net.dinglisch.android.taskerm/net.dinglisch.android.taskerm.MyDeviceAdminReceiver">
<policies flags="8" />
</admin>
</policies>

Reboot the device and Tasker would now be found enabled as Device administrator. However, all other apps previously enabled as Device administrator would eventually be found stripped from that privilege. You would have to manually grant them the privilege from Settings app.

For any reasoning, see my answer here: How to enable device administrator for specific apps using Tasker?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.