Android 5.0 has a new "feature": If a wifi network has no connection to the internet, it will remain connected to it but route traffic over mobile data instead. A small exclamation mark shows in the status bar over the wifi symbol.

Unfortunately, for some reason Android has decided that my home wifi does not have a good internet connection - which is not true, as I'm using it to access Stackexchange at the moment - and is, instead, trying to send everything over GPRS.

With mobile data disabled, things work over wifi just fine, despite the exclamation mark - so it isn't a problem with the wifi not working, per se.

Is there any way to override this "smart" feature? The only way I have found to make things work at the moment is to disable mobile data while I am in my house - which is not a practical long-term solution.

EDITING to add that I have now solved this problem by buying a new router! I was using something very old... But, I'll leave the question here for the benefit of anybody else with the same difficulty.

  • I'm a developer and I connect to a special device via WiFi, I've the same problem but I've no solution for now. Let me know if you find a something, thanks. – Seraphim's host Nov 17 '14 at 22:46
  • I remember there is a similar option to enable/disable this on KitKat, but yeah, I don't know why Google removed it on Lollipop. Then, there is a WiFi dropping case on Nexus 4 that made this a lot worse. – Andrew T. Dec 1 '14 at 6:37
  • @Andrew What are you talking about on Kitkat? Please explain :) – Seraphim's host Dec 19 '14 at 14:35
  • @Seraphim ah, I was talking about "Avoid poor connection" on Jellybean and KitKat WiFi advanced setting, which I don't see it anymore on Lollipop. I thought it's replaced by "Aggresive WiFi to Cellular handover" on developer menu, but it seems I was wrong. – Andrew T. Dec 19 '14 at 15:56
  • @AndrewT. Ah yes, I know. Thanks – Seraphim's host Dec 19 '14 at 15:57
up vote 6 down vote accepted

Just disable captive portal detection. In the terminal, or in adb shell, issue the command

settings put global captive_portal_detection_enabled 0

and reboot.

When you are connected to your home wifi do you see the notification to 'Sign into Wi-Fi network'? If you tap on that item and then the 3 dots menu you will have the option to 'Use this network as is.' I'm in a similar situation as @Seraphim's host and so far this solution seems to be working.

edit: This solution isn't working 100% fo my situation, hopefully it will help for yours though.

  • No, I don't see that. – Flyto Nov 20 '14 at 22:37
  • 1
    This option is on the "Sign in to network" dialog/screen - see here. – Mr. Buster Dec 3 '14 at 18:23
  • @Mr.Buster ...which would be great, if I ever saw that screen :-) Presumably that page is only shown if Android thinks it is behind a captive portal. – Flyto Dec 9 '14 at 8:05

protected by Community Dec 3 '14 at 17:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.