7

Got me a shiny new Hudl 2 (8.3" Wi-Fi tablet with Android 4.4.2).

It's nice. It does the gmail and the facebook, etc.

What it doesn't do is play video from youtube, or other sources such as the BBC. This is either using the Youtube android app or inside the android chrome browser.

The behaviour is as follows:

  1. Video box is displayed but is paused and shows the 'play button' in the centre (the right facing triangle).
  2. Clicking on the play button, a few frames will play, maybe less than half a second of sound.
  3. Then it wall pause again. 'Play' button is displayed in the middle of the frame.

It's like as soon as you press play, it immediately pauses again. Constantly tapping the 'play' button gets a stop animation of the video.

I have tries the following to fix it:

  • Un-installing and reinstalling the Youtube application.
  • Clearing the Chrome browser cache (don't know why that was necessary but one website seemed to think it could fix it).
  • Lowering the quality of the video, even down to the lowest possible setting.

I've tried this on both my home wifi and one other. In both cases, my Samsung Galaxy S4 (also Android 4.4.2) has no problems playing the exact same videos.

So, any advice?

migrated from superuser.com Nov 17 '14 at 11:28

This question came from our site for computer enthusiasts and power users.

  • Does your tablet have motion controls or any smartpause thing like Samsung does? If so disable it. – henrikx Nov 17 '14 at 14:12
4

The trick was to put the tablet into Airplane mode and then to take it out of Airplane mode again.

Unlike just disconnecting and reconnecting the wifi link, this actually unloads and reloads the wifi stack.

Since I did this, it plays videos from youtube, iPlayer, etc just fine.

  • Thanks for your solution. Does this get worse over time? Thoroughly frustrated with this bug – Script Kitty May 13 '16 at 2:41
  • :O works.... what is the reason for this? I not find a way to tell my client to do these steps so that can work. I am ashamed – jose920405 Sep 16 '16 at 17:17
  • I don't know why this problem occurs. However, Air-plane mode will completely switch off the Wi-Fi and Bluetooth RF and I am told that when you exit air-plane mode these protocol stacks are re-initialised. – Simon Peverett Sep 19 '16 at 14:51
  • Thanks man, i found the reason here stackoverflow.com/questions/32238156/… – jose920405 Sep 19 '16 at 16:24
-2

I had similar problems, but after un-rooting every YouTube video seems to be working perfectly again.

  • That's very odd. Have you tried finding a reason for this solution? – Firelord May 28 '15 at 14:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.