0

I used Linux Deploy on Kitkat before and it worked. Now that I updated my Nexus 5 to Lollipop (Chainfire-rooted the device), I installed Linux Deploy again, but whenever I would like to create the disk image or virtually do anything else, I obtain Configuration file not found! or Updating configuration file... fail. I tried various settings, also enabled Wi-Fi while the application is running... no success. Has anyone been able to run Linux Deploy on Android 5.0 or know how I can get the configuration file?

2 Answers 2

1

You need to install Busybox to be able to update the configuration file. However, on my Nexus 5, I haven't been able to get past "Updating configuration file ... done" after the fact. It could be incompatibility or some settings need to be tweaked first. I'll report back if I fix it.

2
  • Thanks, now I experience the same as you. Enabling debug info, I obtain: [22:44:34] tmp-mksh: <stdin>[1]: /data/data/ru.meefik.linuxdeploy/linux/bin/linuxdeploy: No such file or directory How can one fix that? Nov 19, 2014 at 3:48
  • I tried to play with the permissions (as this seems to be the problem as the file does exist), but wasn't successful yet. Nov 19, 2014 at 19:28
0

Quick Answer: Verify the path/file really exists, using a "terminal emulator" or an ssh connection to your Android (not a graphical file browser).

First thing (as Marius Hofert suggest) is to enable "debug info". You will see the full message of the issue.

While installing I saw many "No such file or directory"

Someone suggested to change the directory and after many changes I got it installed & running.

But something changed and I couldn't run the installed OS anymore after shutdown (same messages).

I installed an SSH Server and started checking permissions and files, and guess what, the folder does not exist indeed.

The default configuration (on my phone) has
/storage/emulated/0/linux.img
but (on my phone) the file is in
/storage/emulated/legacy/linux.img

(to be honest it is in /storage/emulated/legacy/linux/linux.img but the example above seems closer to what most people may find).

But that's not all. Using a graphical file explorer, I DO can see

/storage/emulated/0/
/storage/emulated/legacy/

but the first (/0/) looks different, like if it were a symlink (symbolic link).

Maybe "Linux Deploy" is getting lost because of that, so better use clear, reliable paths.

Again, I did my verifications using a ssh connection.

I hope it helps others. I provided the troubleshooting so others can help themselves too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .