3

I've just updated to Android 5.0 and it has already showed that I need some time to get used to the new layouts and such. That's not really the issue though.

The thing that I couldn't wrap my head around was this:

Music
Click for full size

It quite looks like they forgot to put in the Previous button. Is there any way I can get it back?

Thanks!

5

Swipe down on the notification to expand it and you'll be able to see the previous button. It's only visible in the expanded notification, not the summary version. As far as I know, there is no way to change this.

Note, however, that this does not appear to work if you have the lockscreen set to hide "sensitive" notification information:

[...] I have the lock screen notifications setting set to hide sensitive information, and thus it's locking out the full music player controls. When I swipe down, I get the unlock keypad, because Lollipop wants me to unlock my phone in order to get at the full music player. [...] – Derek

Left is the "before" picture, right is after swiping down on the notification:

enter image description here   enter image description here
Click either image for full resolution

  • 1
    I should have found that out by myself ;) . I really don't like how they have degraded my music to just a notification... – Steve Nov 19 '14 at 10:59
  • Does anyone else get the behavior when doing this that the keypad for unlocking your phone comes up as you swipe down on the music controls, making it such that you can't actually expand them completely? I'm guessing this is a bug, probably when there are no other notifications on the screen, but it's highly irritating. – Derek Nov 20 '14 at 14:14
  • @Derek: I haven't seen that myself. The keypad only appears if I swipe up. I haven't tried when the music controls were the only notification, though, because I always have Tasker and BitTorrent Sync running (as in my screenshots above). Sounds like a possible bug to me as well. – eldarerathis Nov 20 '14 at 15:36
  • @eldarerathis: I just realized what's happening. I have the lock screen notifications setting set to hide sensitive information, and thus it's locking out the full music player controls. When I swipe down, I get the unlock keypad, because Lollipop wants me to unlock my phone in order to get at the full music player. If I set the lock notification setting to show all info, then the swipe down works as described here. This is incredibly irritating, as I really miss the embedded music player controls of KitKat but don't want to open the lock screen up to sensitive stuff. – Derek Nov 20 '14 at 16:10
  • By the way, this Android bug report is basically asking to alter how the music notifications work on the lock screen. If this bothers anyone else, too, feel free to press the star button on this bug report page to vote this setting change for consideration. – Derek Nov 20 '14 at 16:17
1

I wanted to keep "Hide sensitive information" selected so that my texts, emails, etc. don't come through on the lockscreen, but I still want my music widget.

Here is what I did:

  1. Keep the option "Hide sensitive information" selected.
  2. Go to Settings > Sound and notification > Application notifications
  3. Scroll down "Music" and select it.
  4. Set "Priority" to ON.

Now I get the music widget with the pause and skip buttons and if I swipe down on it I get the full controls.

Hope that helped!

0

Solution to having full music controls while hiding sensitive information from emails etc on the lock screen:

Go to settings (sounds and notification) 1.Enable show all notification content 2.Directly underneath (show all notification content) select app notification (select the app you want to hide sensitive info) - a new option has appeared (sensitivity) 3. Switch on sensitivity for all the apps you want their info hidden

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.