24

I upgraded my Nexus 4 to Lollipop a few days ago but I don't like it. I'll leave out my reasons because they're not relevant here. I wiped my phone and installed a clean stock 4.2.2 version instead. I'm happy with this.

Not long after, Android automatically downloaded the 4.3 upgrade and notifies me with the choices "Later" and "Install". I don't want to do this upgrade.

How do I:

  • get rid of the notification, and
  • remove the downloaded update (to free up precious storage space).

I have already tried choosing "Later" but the same notification immediately reappears.

Based on Google search results, I also tried going to Settings > Apps > All > Google Services Framework and unticked "show notifications" but it still appears. Force stop or disable also doesn't seem to help, so I've re-enabled the service including notifications. I didn't see any other apps in this list that sounded relevant - did I just not see it?

  • Related: our ota-update tag-wiki / Is it possible to stop notifications of an OTA update? Guess you chose the wrong place to "disable notifications" – it should be Settings › Apps › All › Software Update according to the linked post. Does that work? – Izzy Nov 19 '14 at 13:50
  • Thank you @Izzy - unfortunately there's no app named "Software Update". I have the list sorted alphabetically and there's nothing between "Skitch" and "Sound Recorder". – Torben Gundtofte-Bruun Nov 19 '14 at 15:29
  • Might be named "slightly different" (manufacturers, you know – and you didn't name your device). I'd check all apps to see if there's something that might match. Have you? Maybe it's "OTA Updater", or just "Updater". – Izzy Nov 19 '14 at 15:32
  • You're right - I forgot to mention that it's a Nexus 4! (How could I have...?) I can't investigate right now but will respond later. I believe I did scroll carefully through the entire list already but I must have missed it if there's really an app with a self-explanatory name. – Torben Gundtofte-Bruun Nov 19 '14 at 15:35
  • Never hurts to check twice :) Please also edit your question to include the device name, as it might "get lost" in the comments. Thanks, and good luck! – Izzy Nov 19 '14 at 15:37
28

You can disable these notifications by unchecking the notifications for Google Play Services [Not Framework]. This fixed my problem on the LG G3 and I assume it will on all other devices.

The best option is to click and hold the notification and then select 'App info', which will take you to desired app info for that update notification. Then uncheck the notification option there.

  • 4
    Go to Settings > Application Manager > All > Google Services Framework and then uncheck "Show notifications". source – Torben Gundtofte-Bruun Feb 10 '15 at 22:02
  • 3
    For Lollipop, it is "Apps" instead of "Application Manager" – Freedom_Ben Mar 18 '15 at 19:59
  • After un-check notification in "Google play service". The notification was still in panel. I did long touch it, then from menu select "app info" and force stop. Will see if it appear again... – Vit Bernatik Jun 2 '15 at 9:55
  • Since my question was marked as a dupe. This does not work on a Galaxy S5 nor on a nVidia Shield K1. Both Google Services Framework AND Google Play Services have had notifications unchecked. The popup upgrade still persists. Log pressing on the notification takes me to System Updates app and the "Show Notifications" is checked but can not be unchecked. I have force stopped but it, of course, comes back. – Wolfie Jul 1 '16 at 15:51

protected by Community Mar 22 '15 at 4:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.