5

I have a Nexus 5. It has TWRP as the custom recovery and on official Android 4.4.4 KTU84P build.

I just received a notification that I'm able to update to Android 5.0 now via OTA. I'm aware that I'll have to re-root my device. But, is it safe to update it with its current state? I already did a Nandroid backup hours ago, BTW. What else needs to be done pre and post-update? Thanks.

UPDATE: I backed up all my files then did another Nandroid back up. I downloaded the update via OTA and was asked to restart my phone. But it went straight to TWRP, doing nothing.

So I restarted my system via TWRP. It's still on 4.4.4 and the Lollipop update does not show anymore. What happened there?

5

The answer is the update won't push through if you have a custom recovery like TWRP. I had to restore the stock recovery using the Nexus Root Toolkit. Then the update showed again, and it went through flawlessly. Even the re-rooting part (again using NRT) was perfect.

  • Sounds promising, but I found it strange that you only had to go back to stock recovery. Your system partition should have been modified when you rooted (added su) and then Android wouldn't update via OTA was my understanding. Anyone care to explain this? I might add that it worked for me as well. Followed your procedure. Thanks! – riper Nov 22 '14 at 15:22
  • I don't really know much about that, but when I got this phone, it was on Android 4.3 IIRC. Rooted it immediatly, but retained the stock recovery. Come 4.4.4, had no trouble updating and only had to re-root my device. Pretty much like this case except I had TWRP. – d4ryl3 Nov 22 '14 at 18:14
  • When you rerooted after installing the OTA, didn't you lose all your data (as usual when rooting) ? If yes, what was the purpose of using NRT anyway (you could as well have flashed)? – riper Nov 23 '14 at 10:06
  • Nope, didn't lose a thing after the OTA. I only used NRT to re-root the device. Its latest update supports Lollipop. Also because I'm yet to try manually rooting via ADB. – d4ryl3 Nov 24 '14 at 17:23
0

From my experience there was a problem with updating regarding the "signature" on Nexus 5(4.4.4.). The device itself was rooted and in my case with CVM instead of TWRP.

Since it failed to install the update I tried to flash 5.0 image from this Google site and followed the instructions.

The default instructions did not work due to in some cases faulty all-script therefore this instructions helped.

I hope the answer helps. For manually updating to Android L the first link should be helpful as well

Not the answer you're looking for? Browse other questions tagged or ask your own question.