I've updated my non-rooted, vanilla Nexus 5 with an OTA update to Android 5.0 Lollipop and since then my custom mp3 ringtone stopped working. Here are the symptoms:

  1. When selecting it via the ringtone selector in the Sound & notification settings panel, it plays properly.
  2. When someone else calls me, the default system notification sound is played repeatedly.
  3. Re-uploading the custom ringtone via AirDroid as an .mp3 file didn't work, nor did uploading an ffmpeg-encoded .ogg version of it.
  4. The same applies to my custom notification sound.

I'm currently using one of the ringtones bundled with the system, and I'd love some help in solving this problem. Thanks!

2 Answers 2


A friend suggested clearing cached data (via Settings > Storage > Cached data) and then rebooting, and it seems to have resolved the issue.

  • My mobile wasn't ringing when there is a incoming call. I updated from kitkat to lollipop a week ago but this issue came just today. I did as given and it worked!!!
    – Gopi
    Dec 1, 2014 at 9:49

Your steps should have fixed the problem unless you have uploaded the file to the wrong directory and it's still showing the broken link to the older file.

  1. Check that you are uploading to /sdcard/Ringtones
  2. Check that AirDroid (I'm not familiar with that app) uploads with the proper permissions to allow the system to access it
  • AirDroid does indeed upload them to the path you mentioned. Terminal Emulator (via ls -l) tells me that their permissions are "-rw-rw---- root sdcard_r" (rest omitted) Nov 22, 2014 at 11:46
  • In that case, I'm lost. Those are the correct permissions.
    – HSuke
    Nov 23, 2014 at 22:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .