2

So, I'm currently on the N5X rom with a cyanogenmod 4.4.4 base on my Samsung i9300, I restored Chrome Beta from one my backups in titanium Backup, after flashing the latest version of the ROM recently.

But every time I launch Chrome or Chrome Beta from the drawer, it comes up, staying right at the center, here's a screenshot:

enter image description here

Its so strange, it doesn't force close or pop up with any errors, everything works fine except for the part where it just starts fixed to the center of the screen.

What I've tried:

  • Uninstalling Chrome Beta and Chrome, and then re-installing both
  • Wiping data and cache of both browsers.
  • Re-flashing the ROM.

So here's what I've noticed, sometime last month when I flashed a Paranoid Android nightly, both Google Browsers behaved this way, and I thought it had to do with P.A then until this happened. Firefox works fine though, just Chrome and Chrome Beta.

  • What if you reinstall it through Google Play instead of by restoring from TiBu? – Dan Hulme Nov 20 '14 at 21:01
  • I already did that for both Chrome and Chrome Beta. – Feyisayo Sonubi Nov 20 '14 at 21:12
  • In that case my best guess is that it's caused by the theme customizations in this ROM. Likely the Paranoid Android build you tried had the same problem. You might try putting the developers in touch with each other to help them fix it. – Dan Hulme Nov 20 '14 at 22:44
2

This is happening in any custom ROM that supports floating windows. It is there, for example, in SlimKat, Spirit ROM, CM based ROMs etc. In my case I can move and size the window, and there is a maximize button available. It resizes the window with pinch to zoom automatically rendering it almost unusable.

This is an app issue ultimately, but it is specific to custom ROMs with this functionality.

The only thing you can do it, open the Chrome window then bring up the task manager and select Chrome and it will fill the screen as normal. This is obviously an awkward work around.

Alternatively if you have Xposed installed you can try to Blacklist Chrome from xFloatingWindow and see if it will work. Some, but not all have had success with this.

2

According to AndroidPolice is actually caused by a bug in Chrome Beta that showed up on certain custom ROMS. The recent update (v39.0.2171.90) contains a fix for this issue. It's likely that the next update for non beta Chrome will include a fix for this too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.