0

I want to access my external HD attached to Raspberry PI, so I've installed SMB server on it, and CifsManger on my MTK6572 device (rooted, busybox installed). I've tested the SMB server with my desktop machine, and it works.

CifsManager says that I have to install cifs.ko. I have downloaded one and copied to the device, but insmod says:

# /system/bin/insmod cifs.ko                          
insmod: init_module 'cifs.ko' failed (Exec format error)

I've tried ones from other sources, but the result is the same.

My configuration:

# cat /proc/cpuinfo                                   
Processor   : ARMv7 Processor rev 3 (v7l)

Kernel version is 3.4.5.

I'm not sticked to CifsManager, I just want to mount the HD on my device, so all programs should use it. (File managers can see SMB and SSH servers, but they don't mount.) I can install any file server service on the Raspberry Pi.

EDIT: I've used file command to determine the exact type of my existing .ko modules:

$ file /media/peklapat/system/lib/modules/devapc.ko 
  /media/peklapat/system/lib/modules/devapc.ko: 
  ELF 32-bit LSB relocatable, ARM, EABI5 version 1 (SYSV),
  BuildID[sha1]=*cut*, not stripped

Edit2: Modinfo says:

  $ modinfo /media/peklapat/system/lib/modules/wlan_mt6582.ko 
    filename:       /media/peklapat/system/lib/modules/wlan_mt6582.ko
    license:        GPL
    description:    NIC_DESC
    author:         NIC_AUTHOR
    depends:        mtk_stp_wmt
    intree:         Y
    vermagic:       3.4.5 SMP preempt mod_unload ARMv7
  • Do you have kernel source for mtk6572 device? – RRD Nov 22 '14 at 4:44
  • Nope. But MTK6572 is not a rare animal, lot of phones, tablets and TV sticks are equipped with it. – ern0 Nov 22 '14 at 12:16
  • try this one forum.xda-developers.com/… might work for you – RRD Nov 22 '14 at 12:28
  • Nope. I've used file to determine exact type of my .ko files, I added this info in the question. Anyway, thanks! – ern0 Nov 22 '14 at 12:47
  • Hm, file says the same for the .ko-s you've sent, why insmod keeps saying the same error (Exec format error)? – ern0 Nov 22 '14 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.