1

I have an Android phone from LG, and I want to use it for USB debugging. I followed the following steps:

  1. Enabled usb debugging in developers option on phone.

  2. After connecting to PC, phone shows as "Usb debugging connected". I verified the same by running lsusb on Ubuntu 14.10. It shows the following result:

    Bus 002 Device 003: ID 1004:633e LG Electronics, Inc.
    
  3. Then I followed steps given in https://developer.android.com, to setup hardware device.

    • Log in as root and create this file: /etc/udev/rules.d/51-android.rules.

    • Use this format to add each vendor to the file:

      SUBSYSTEM=="usb", ATTR{idVendor}=="1004", MODE="0666", GROUP="plugdev"
      
    • Now execute: chmod a+r /etc/udev/rules.d/51-android.rules

  4. After that I rebooted the computer.

  5. Now when I try to check device list in adb by command ./adb devices, it does not show the device listed.

Can anybody please help? Where am I going wrong?

  • Does it show the USB debug option to be activated in you status bar? – maxpesa Nov 23 '14 at 19:10
0
  • Try running commands as root from your adb folder:

sudo ./adb kill-server; sudo ./adb start-server; sudo ./adb devices

0

On the device, change USB connection mode from MTP to PTP.

Credit/source: http://forums.linuxmint.com/viewtopic.php?f=18&t=183642

Worked for an LG G Pad 10.1 (V700).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.