I'm using a Galaxy Ace. When I turn off WiFi and try to turn it on again it shows an error. I need to restart my device for it to work. Any ideas?

  • Can you give the specific error?
    – ale
    Jul 14 '11 at 13:18

I believe this is a problem with Samsung's UI, TouchWiz; I experienced this on a couple ROMs for my Galaxy S.

I don't know of any way to fix it without replacing your ROM, but I did find that going to Settings -> Wireless and network -> WiFi settings and toggling WiFi there seemed to work. Settings is a standard Android OS app and thus bypasses whatever problem TouchWiz has when you try to toggle the WiFi from the notification area.


You can try this, on the dial pad, enter *#*#526#*#* this will automatically load the wifi drivers. Once you see that driver loading successful, you can then turn on the wifi and it might work...


I believe this is a problem of the ROM itself (Android 2.2 in Ace). Even with only the basic applications it would show the same error.

Anyway this problem is solved for me. I upgraded my phone to Android 2.3.4. After that, up to now (nearly 5 month) I haven't come across that problem.


I did have a problem a few months ago where I'd keep getting an error when I tried to turn Wifi on, which needed a reboot of the phone to fix.

I traced it back to an app that I'd installed recently, the app in question monitored the wifi connections and did funny things ensuring you connected to specified wifi points when they were available. After I uninstalled the app the problem went away (the app in question was the BT FON app, in case you have the same one).

So it's probably worth thinking about when the problem first started, and then working out which apps that have anything to do with wifi you may have installed or updated around that time, and removing those apps for a few days to see if it helps.

  • @GATwrawn: what you are suggesting is installing BT FON app, uninstalling it and that it? My WiFi issue should dissapear? Also, could you please give me the link to download that app (there is more than one which starts with "BT FON" in the market).
    – Diego
    Jul 14 '11 at 13:05
  • @Diego no, what I'm suggesting is that a problem app could be causing this, so try uninstalling any apps that interact with Wifi or networking in any way. BT FON was just the app that turned out to be causing my problem.
    – GAThrawn
    Jul 14 '11 at 16:11
  • OK, I'll try. Would this be any app which uses internet? If not, how can I know when an app intercat with Wifi?
    – Diego
    Jul 14 '11 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.