2

After updating my Nexus 5 to Android 5.0 I noticed that alarm is not fired at set time (actually that spoiled my today's morning).

When I set time for alarm it writes correct delta (e.g."Alarm set for 3 minutes from now"), but it doesn't make any sound or any on-screen changes in 3 minutes: the alarm just hangs in notification tray as an "Upcoming alarm".

I've checked the notification settings and didn't find any problem. but the notifications from Google Keep don't work as well...

What can be wrong with built-in alarm in Android L?

  • Did you turn on "Priority Mode" to "None" by any chance? – Andrew T. Nov 25 '14 at 9:26
  • Nah, it was the first thing I checked :( – Dmytro Titov Nov 26 '14 at 7:48
  • Did you ever find out the cause? I have the same issue with my Nexus 4 – Ian Clark Nov 26 '14 at 9:23
  • 1
    In the end I just factory reset. That did it :( – Ian Clark Nov 26 '14 at 12:01
  • Some debugging I'd like to ask: did you have two factor authentication for your default Google account? I thought it might be the cause because I couldn't authenticate and I wasn't logged in. – Ian Clark Dec 21 '14 at 11:40
2

Well, I couldn't find the solution so I followed Ian Clark's advice and performed factory reset. That helped.

1

I went through and stopped all of the Google Play Services (Settings->Apps->Running), including the cached process(Settings->Apps->Running->Show cached processes). It takes persistence, since they restart sometimes, keep at it and kill them dead. Restart when you get them stopped.

I get text's again (these would previously show as "Downloading 1KB") and the alarms go off now.

Hope this helps someone else, or at the very least saves them the hassle of a factory reset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.