When I reboot the phone, often, some of the apps a get generic icon and won't load anymore.

A reinstall solves the problem but I'd rather not have to do that.

Device is an Acer Liquid Metal with Froyo.


I finally found out why! :D

When the phone boots - at least if I use go launcher - if the sd card is not completely mounted apps "get lost". I've completely solved the problem activating my phone card pin code. I turn on the phone, wait on the pin code screen without entering it for a minute and then I enter the pin: everything is perfect. I think the problem can be also solved killing and restarting the launcher but I didn't test.

|improve this answer|||||
  • 2
    I want to confirm that the suggested answer/explanation works for me too. I've had this issue with my Acer Liquid Metal from the start, and sometimes it would be just one or two apps disappear, sometimes more. If you wait awhile before entering PIN code for SIM, all the apps are there. – user5412 May 25 '11 at 15:15
  • Horray! I'm glad you did it too :D – Pitto May 26 '11 at 17:50
  • 1
    you can also solve it using Tasker. See here: android.stackexchange.com/questions/10497/… – Diego Jun 29 '11 at 19:24
  • @Diego Doesn't that just run apps? How does it cause the launcher to reload the app info? – Matthew Read Jan 13 '12 at 3:14
  • Waiting does not help. It helps only to uninstall the app and reinstall it again. Installing it above the existing one, without uninstalling it first, helps until reboot. After reboot the app disappears. – Paul Jan 23 '14 at 23:42

Have you moved them to or from the SD card? My app icons disappear from my home screen when they are moved.

|improve this answer|||||
  • Yes I did... But I'd like to find a solution for this behaviour and keep my app to the sd. I got just a little memory on the phone side (Acer Liquid Metal) – Pitto May 3 '11 at 15:49
  • 1
    Create the shortcut after moving it to the SD. Or delete the shortcut and re-create it. – Matthew Read May 3 '11 at 15:51
  • The problem is that applications in Application manager turn into gray like they're not correctly installed :/ – Pitto May 3 '11 at 17:12
  • @Pitto Oh, that's definitely a bigger problem. Hmm. – Matthew Read May 3 '11 at 17:13

I sometimes have this problem with my LG Optimus V. I used to re-install the app(s), now I just reboot the phone again--works 9 times out of 10 (and with those odds, the a second reboot handles that 10th time).

|improve this answer|||||

Finally I found it

Settings > apps > apps settings > disable all apps > apps settings > enable all apps

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.