On Windows7, I've updated the Google Glass android_usb driver configuration file to reflect the correct VID and PID and it does show up on Device manager as Android ADB interface.

  1. While the device driver version is correct, it is showing up as SAMSUNG Android phone.
  2. More IMPORTANTLY, it still doesn't connect to adb.

Google Glass in Device mgr but not in adb


I had the same issue. Glass was showing as SAMSUNG Android phone as well. My steps to fix issue:

win7: https://stackoverflow.com/questions/20435778/google-glass-is-not-listed-as-android-device-by-adb

  1. Click on: Update Driver
  2. Click on: Browse my computer for driver software
  3. Click on: Let me pick from a list of device drivers on my computer
  4. Click on: Have Disk... (that options is in the bottom right corner)
  5. click on: Browse...
  6. navigate to the location of your edited android_winusb.inf driver then click open then click ok then click next
  7. wait a moment then you should see "Windows has successfully updated your driver software". then click close and close again.

!!!(now here is the important part)!!!

  1. Right click on the device and click uninstall.
  2. check the box "Delete the driver software for the device" then click ok
  3. wait about 5 sec then unplug your Google Glass from the computer. wait 5 more sec then plug it in.
  4. Watch the magic happen!!!! its working!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.