0

This question already has an answer here:

I'm trying to root my android using adb from a linux distro. When I run

fastboot flash recovery recovery-clockwork-5.0.2.0-blade.img I get

> sending 'recovery' (3768 KB)... OKAY [ 0.142s] writing 'recovery'... FAILED (remote: partition 'recovery' not support flash ) finished. total time: 0.155s

I'm following this site http://rootearandroid.com/zte-kis/

I have looked the solution since a while but there are not specifics about my android, I guess adb is not working correctly. What can I do?

marked as duplicate by bmdixon, RossC, Sid, onik Dec 17 '14 at 10:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • It the same problem but different model whose issue has not been resolved – Maharba Dec 16 '14 at 21:55
0

Download SuperSU (zip) 4 on your PC, if you haven’t already.

Connect and mount your phone USB memory on your computer using the USB cable.

Now copy/paste the zip file to your SD card. Make sure the file is in the SD card root (not in any folder).

In ClockworkMod recovery, scroll down to “flash zip from SD card” and press the power button to select it.

Press the Power button again and select “choose zip from sdcard”.

Now using your volume keys, navigate to SuperSu zip and select it using the Power button. Confirm the installation on the next screen and the installation procedure should start now.

After the installation completes, go to “+++++Go Back” and reboot the phone by selecting “reboot system now” from the Recovery menu. The phone will boot now and it might take about 5 minutes to boot on your first time. So, please wait.

RTeran.

  • Tanks for your answer Rafael, I have already tried to do it but when I flash the image, it returns the partition error. I'm no able to zip from sdcard becuse my current recovery does not support that option. However I followed you suggestion about Root it with Supersu and used Framaroot, and I get it only using the 1.5.3 version and installing supersu. The most recent version of Framaroot (1.6.3) is a mess. In fact I decided to share my procedure here link . Thanks a lot – Maharba Dec 18 '14 at 15:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.