6

I have recently started getting dialog popping up asking to enter password every time I connect to my home Wi-Fi hotspot:

enter image description here

This dialog always pops up when you connect to hotspot for the first time and then it memorizes password so you don't have to type again when reconnecting. Until now, reconnection was automatic. A couple of things to suspect might be recent upgrades from 4.3 to 4.2.2 and a week earlier to 4.4.4

In addition I recall that I accidentally turned off Wi-Fi settings icon from appearing in Android's task manager which was before final upgrade if that helps.

Anyone knows what can be the cause? I have LG Nexus 4 E960

  • Question is now updated – Boris_yo Nov 26 '14 at 13:07
  • I think setting static IP helped. – Boris_yo Dec 6 '14 at 17:28
2

Here is the solution which worked for my rooted Nexus 5 (Android 5.0.1)

make a backup of wpa_suppliciant.conf file and DHCP folder. Just in case.

  1. Copy wpa_suppliciant.conf file from /data/misc/wifi/ to your PC
  2. Open with any text editor (I used wordpad) and delete all entries with you problematic wifi name on it.
  3. Choose one of the Wifi in the list which you remember has worked before and change SSID and passkey according to you router. Press SAVE.
  4. Copy/replace this modified file into /data/misc/wifi
  5. Delete DHCP folder in /data/misc/
  6. Reboot your phone.
  7. Your phone should now connect to your new wifi :)
| improve this answer | |
  • Thanks. I think problem solved itself when I updated to KitKat. – Boris_yo Feb 1 '15 at 10:39
1

While I can't think of any specific things right now that would cause the LG to drop the connection (except for maybe a pretty busy network), there are things you can do to prevent it, although this may not work with every device the first thing you should try is to "Forget Network" and start clean.

You were right about the Static IP, it could help as it prevents the router from assigning the IP to other devices around the home. There could be numerous factors contributing to this so I hope the problem is solved now (as the question is 2 months old now).

If you still have problems, it really pays to take your phone to your local tech center and get some professional advice (this is often free :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.