2

I mistakenly installed 5.0 Lollipop on my nVidia Shield tablet, and I regret it. Is there a way to revert back to KitKat? I've tried finding a way, but no luck so far.

3

One way would be to flash a factory image to your tablet, which would restore it to the state it was when you first bought it.

Depending on your model (wifi, or wifi + lte), you can find official factory images to for the SHIELD tablet on this nvidia website:

https://developer.nvidia.com/develop4shield

Following the relevant links, you will get to a website from where you can download the factory image. The bundle should also contain instructions. Hope this helps.

1

I have just gone through the whole process successfully. Below you find all the necessary steps for a downgrade for OSX (and likely for linux).

Install the Java8 Runtime

from here: https://support.apple.com/kb/DL1572?locale=en_US after installing, verify from command line if this runs without issues

java --version

Download the Android SDK

Obtain it from: http://developer.android.com/sdk/index.html Then you have to execute this command to download fastboot:

./android update sdk --no-ui

You only need the fastboot executable, which you can easily find:

~/Desktop/SHIELD/android-sdk-macosx: find . -name fastboot
./platform-tools/fastboot

Then add its directory to the path:

export PATH="$PATH:$PWD/android-sdk-macosx/platform-tools"

Download the Factory Reset Images

From https://developer.nvidia.com/gameworksdownload pick the NVIDIA SHIELD Tablet WiFi Recovery OS Image for linux. Make sure you download the Update 1.2.1, this is the last one before Lollipop was introduced (I also tried with the factory image, but the tablet was freezing very often). Then, unzip it from the command line, then execute the shell file.

unzip extract-nv-recovery-image-shield-tablet-wx_na_wf-19485_417.6426.sh.zip 
chmod +x extract-nv-recovery-image-shield-tablet-wx_na_wf-19485_417.6426.sh
./extract-nv-recovery-image-shield-tablet-wx_na_wf-19485_417.6426.sh 

Everything that follows is performed in the folder where you unzipped (it contains a few *.img files)

Put your SHIELD tablet into fastboot mode:

  • Turn off the device
  • Press "Volume Down" -> "Power", hold "Volume Down" and leave Power buttons till device boots

Flash the tablet

fastboot oem unlock /// AND FOLLOW SCREEN INSTRUCTIONS
fastboot flash recovery recovery.img
fastboot flash boot boot.img
fastboot flash system system.img
fastboot flash userdata userdata.img
fastboot flash staging blob
fastboot flash dtb tegra124-tn8-p1761-1270-a04-e-battery.dtb
fastboot reboot-bootloader

Reboot the device

Use the volume up/down and the start button to select "reboot" when the commands above have completed.

Reference to the official instructions (not as verbose)

https://developer.nvidia.com/sites/default/files/akamai/mobile/docs/HowTo-Flash-SHIELDTablet-Recovery-Image.txt

protected by Community Feb 11 '15 at 13:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.