1

I have a Nexus 4, and finally decided yesterday to update to Android 5.0, after being fearful of bug reports. And wouldn't you know it, I've found a nasty bug.

Nearly every time I try to display the list of Wifi networks in the Settings, the system freezes for about a minute, then I get prompted saying

Settings isn't responding.
Do you want to close it?
REPORT WAIT OK

If I wait long enough (by hitting 'wait' or 'report'), then I eventually get the list of wifi networks, and everything appears to work normally* from that point.

If it's relevant, my phone also has the problem described in this question, and the update to Lollipop didn't fix it. So I'm thinking a factory reset may be in order....

*I say normally, I had to wait a similar amount of time to authenticate to the network at Starbucks through the authentication web site, but once I was authenticated, everything appeared to work normally. I have no idea if this is actually a related problem, so I only mention it in passing.

  • I won't be any consolation, but I have the exact same symptoms you observe on my Nexus 4 and have been search forever for a solution and no suggestion I tried works. – kynan Nov 30 '14 at 10:26
  • @kynan: Did you try a factory reset and it didn't help? – Flimzy Nov 30 '14 at 12:12
  • I did not, but considering it since it has become pretty much unbearable... – kynan Nov 30 '14 at 13:56
  • I had something similar happen to a friend. Just switched wifi off and back on and it worked. Can't suppose you haven't tried it though. – aandis Dec 18 '14 at 11:57
  • I did a factory reset from the official Google images and have the same bug on my Nexus 4 – Mike Gleason jr Couturier Dec 26 '14 at 2:58
1

I had this problem recently and solved it by removing old saved networks in the WiFi settings. I found that there were a huge number of networks with names that were strings of letters and numbers.

  1. To remove saved networks open 'Settings' and choose 'Wi-Fi' (and wait for it to load).
  2. From the 3-dot menu choose 'Saved networks'.
  3. You should see a list of networks in a similar format to those shown below: WiFi Listing

  4. Remove any you don't recognise (tap the network name and tap 'Forget'): WiFi Delete

Once all of the unrecognised names have been removed the list of WiFi networks should load without freezing the system.

NOTE: I have found that this can occur again after a while, in which case repeat the steps above.

  • I didn't find any "unrecognized names"... but there were a ton of wireless networks stored after 2+ years of extensive travel and connecting to random networks all over the place. I have removed those I don't frequently use, and will see how things perform now. Thanks for the tip. – Flimzy Jul 20 '15 at 14:23

protected by Community Dec 18 '14 at 12:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.