0

This question already has an answer here:

Well my dad just bought some phone for me "x-touch ocean" and I've beeeeeen trying to download apps but it keeps saying "insufficient memory on the device" I tried deleting apps I already found in the phone but still.. I got a new memory card with nothing in it but it still says the same thing over and over.. I haven't downloaded anything at all by the way. And I tried to move apps to the memory card but none of them can be moved unfortunately. Please some one help #frustrated 15 year old #

marked as duplicate by bmdixon, RossC, Izzy, Sid, onik Dec 18 '14 at 13:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Additionally to being a duplicate: I've just added the insufficient-memory tag to your question. You might wish to check its tag-wiki for some background (which also includes some first-aid). – Izzy Dec 16 '14 at 22:51
0

Google 1tap cleaner free then download and install it. Clear cache using that app. Then try to download any all from play store again.

  • Do you have a link to the app you're talking about? – Andrew Lott Dec 12 '14 at 18:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.