4

I have had this problem for a couple of days on my first-generation Motorola Moto G. Normally a restart would fix it. However now I am faced with the following error message when trying to unlock the phone after a restart:

Unfortunately the process com.android.systemui has stopped.

The phone has reset the background to the default home screen which disappears when I unlock, going to a black screen. However, it still shows my apps and widgets. Then a second or so later goes back to the unlock screen.

I have tried clearing the cache partition multiple times which has not worked. Ss there any way I can fix this problem without a factory reset, or taking my phone to a phone shop?


Some additional information:

  • I have been using ART on my phone for the past couple of months, but the problem has only occurred recently

  • On boot-up I get the following message:

    Updating Android. Optimizing app 1 of 1.
    
3

Sounds like an ART incompatibility. You probably installed an app recently that doesn't work properly with ART. Presumably it added itself to the start-up apps. That's why your UI crashes when booting up. You will have to find a way to either remove the app in question or go back to the Dalvik runtime.

I went through the same ordeal a month ago when I opted to try out ART. Of the various solutions I found on the internet only this one by androidcentral user sajidr worked. I'll quote it here in case the forum post goes down:

I managed to switch my runtime back to Dalvik. It was painfully slow but in the end I didn't have to do a factory reset.

There's a fraction of a second after unlocking when the screen responds to a touch or swipe. This happens only right after you see the error message popup - "Unfortunately, the process com.android.systemui has stopped". If you do not see this message after unlock then open up the camera from the lock screen & close it.

Next, follow these steps to open up the app drawer - 1. Unlock the phone 2. Once you see the popup "Unfortunately, the process com.android.systemui has stopped", keep tapping on the area where you think the app drawer icon is. At the same time, using another finger click on the OK button of the systemui message box. 3. If your timing's good then once the message box is closed, the app drawer should open. 4. The phone would go back to lock screen but the app drawer would be open. You can validate this by unlocking the phone.

Repeat the above steps to swipe over to your Settings app. Instead of tapping, do short swipes & then click on the message box OK button. Each time the phone would go back to the lock screen but you should be able to slowly navigate over to change your runtime.

Once I got the hang of it, it took me about 15 minutes to go to Settings & change the runtime.

Don't bother trying to uninsintall flipboard from your play store this way. I tried it twice & both times the phone rebooted itself after i clicked the uninstall button.

If your screen layout shifts vertically after the unlock then tap on the area where you first see the icon & not where it moves to after the shift.

Good luck.

Other users have had varying success with booting to safe mode and disabling ART / ART-incompatible apps from there.

You will find more discussion on this issue and possible solutions in these threads:

  • @bennettleben No problem! Glad I could help :). – Glutanimate Nov 30 '14 at 18:48
  • The "Select Runtime" option is gone in my version of Android (Jellybean / 4.2.2). Now what? – Fedor Steeman Jan 21 '17 at 20:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.