0

I've been struggling for the past 3 days with trying to get started with USB debugging for android apps. Currently, my phone is not being recognized by my computer at all. Here is what I have already done/tried:

-Enable USB debugging on phone - check

-Restarted all devices - way too many times check

-When I check device manager to update drivers etc, my device doesn't show up under 'Other Devices' or anything related to the phone but instead under 'Human Interface Devices'

-And when I try to update the drivers from there, it will not work, telling me that the drivers are already at the highest.

-When my phone is plugged into my computer, it charges but even the file explorer does not see that it is connected, I have no way to view the phone.

-I have tried 3 different brands of usb/micro-usb cords to see if that was the problem

-I have updated all drivers for my computer

I've tried many many other obscure things as well but if anyone has any ideas please please let me know!

Running an LG-D631 Vista

  • Does the phone think it is connected? When it does, there's an "ongoing" notification saying "USB debugging connected". – Dan Hulme Dec 1 '14 at 21:37
  • You should look directly on LG's website for drivers. – Matthew Read Apr 9 '16 at 20:07
1

I had a problem with my LG Nexus 4 not being recognised when I connected it to my laptop and in the end this solved the problem for me...

On your mobile:

  1. Go to Settings > Storage > USB Computer Condition (Menu option from Storage Screen)
  2. Change from Media Device (MTP) to Camera (PTP)

After that it was recognised without any issues.

0

I always had these problems with my old phone. Most of the times this helped:

  1. Go to Device Manager right click and choose update driver software
  2. Choose to search for drivers on your pc
  3. Click Search and go choose: "Android SDK Path"\extras\google\usb_driver

If that doesnt help, repeat step 1 and 2 and press "choose from list". Then choose Medium and choose "Android SDK Path"\extras\google\usb_driver\android.winusb.inf. Then you should be able to choose "Android ADB Interface". Click next and press yes and it should install that driver.

Hope this helps you, cause i know how frustrating those problems can be

  • You should add the link for Android SDK, not everybody knows where to get it. – HasH_BrowN Dec 11 '14 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.