I just recently purchased a cheap tablet (DigiLand DL701Q 8gb), as my first foray into Android.

I've been using the pre-installed Chrome browser but I can't figure out how to switch tabs or close them. I've searched for hours and all I could find was that the little square icon with numbers in the top right is the tool for tabs, but tapping it does nothing.

I've tried double/triple tapping and swiping, but it still does nothing. Tapping and holding on it opens a popup message with the phrase "open tabs" but tapping that also has no function. I've tried every combination and method I can think of, but nothing works. Only one time did I manage to switch to a different tab and then quickly close it, but this was a result of me desperately mashing the square icon in frustration and I haven't been able to replicate it.

I currently have 7 tabs open and I have no idea what they are or how to view them or how to close them. Any help would be greatly appreciated.

  • 1
    Please indicate the Chrome version you're using by going to Settings (from Chrome) - About Chrome. Also, indicate the Android version. Different Chrome and Android version might affect this behavior.
    – Andrew T.
    Commented Dec 3, 2014 at 0:43

3 Answers 3


Click the three dots, choose "Settings", then turn off "Merge tabs and apps". Now tabs will work like they used to.

(This solution was improperly proposed as an edit by an anonymous user.)


Much more recently I ran into a very similar problem using Android Chrome. Going backwards to recent prior versions did not fix this. Chrome Beta is working correctly.

Problem: I could not

  • Click/tap on a tab,
  • Click on the X that closed the tab,
  • Click on the plus sign that opened a new tab, Etc.
  • Open the menu in the upper right corner (that only opened a new tab)

I was able to

  • Click on and edit the URL area of the screen, and
  • Click on items within a page.


  • Backing up to recent versions of chrome did not fix this.
  • Resetting tap duration in Android settings temporarily fixed my problem. [See image.] But after adding more tabs problems returned.
  • Closing down Chrome and restarting it also seemed to help, but only temporarily.


  • Using Chrome Beta appears to have fixed this.

Tap duration

  • Samsung tablet SM-T860
  • Android ver. 10
  • Chrome ver. 87.0.4280.101

I had the same problem. I was never able to find a way to exit those tabs so I just went to Settings → Apps → Chrome, then deleted data. Nothing bad happened, and those 8 tabs I couldn't remove are no longer there to annoy me.

  • Note that this also reset all the Chrome setting you have done, if you have tinkered it before.
    – Andrew T.
    Commented Jun 23, 2015 at 7:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .