0

I have a U.S. Sprint LG G3 and I've been trying to make a custom boot & shutdown animation for it, but I'm having quite the trouble.

I have no problem getting boot animations I download from here to work. I was also able to use this person's site to turn the vertical octopus gif in that thread into a boot animation. Phone is rooted only, no custom rom; no problems placing the files and setting permissions correctly.

But I'm not having any luck with this gif: http://i.imgur.com/08thhjx.gif

That site has a 3MB file limit, so I'm trying to create the images and bootanimation.zip myself. I've tried splitting the frames out with both Irfanview & ImageMagick. Then resizing from 480x480 to both 960x960 and 1440x1440 - then expanding the canvas to 1440x2560 and filling the new background in with black. Again, I've performed these manipulations with both IrfanView & ImageMagick.

I've tried jpg's and png's with varying levels of image compression as well as both 24 and 32 bit png's.

In the desc.txt file I've tried 30, 45, and 60 frames per second. For the part line I've tried:

  • p 1 0 part0
  • p 0 0 part0
  • c 1 0 part0
  • p 1 0 part0 (repeat this line x10)

And the zip I create uses Store compression (no compression), created with WinRAR.

No matter what I've tried, the animation never displays, just black screen. I've tried connecting with adb and running the bootanimation command. When I have a working boot animation that I've downloaded, the command echos the string bootanimation at the prompt, and my phone screen flashes black for a split second. When I try the command with my custom animation in place, nothing is echoed at the prompt - no error messages or anything - and nothing happens on the phone.

Here's a dropbox folder with a few versions I've tried - jpgs, larger png's, and smaller png's, with different variations on the desc.txt file. None of them will display. Maybe I'm missing something simple, or maybe there's some problem with the images I'm creating..

0

Did you add a crlf after the last line in your desc.txt file? I could not get mine to play until I hit return after the last line to let the file end on the new line.

Hopefully this is all you need to do too.

  • I tried it both ways, with both dos and unix line endings. – quentin-starin Feb 21 '15 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.