0

I set up the Android Email app on my Samsung Galaxy SIII Neo because I thought I would move from Internet mail on Outlook.com to using Email. The app did not download all my mail but only downloads new mail, which I don't like. Besides, I am too used to using INternet for mail to think about using the Email app. However, the app is giving me annoying notifications all the time, and I definitely don't want to know every time a new email arrives. I prefer to see it on Internet. So how do I eliminate my account from Email? Or how do I turn off the notifications? Or how do I get to see all the mails I have on my Outlook account on the app instead of just the unread mail?

0

To "get rid of it", try the following steps:

  1. From the home-screen, open Settings
  2. Navigate to Apps, tap the "All" tab
  3. Scroll until you find the Email app. Tap it.
  4. Tap the buttons to "Clear cache", "Delete data", "Force stop", and "Disable" (in this order)1

Now that app should no longer bother you. If you wish to use another Email app instead, there are plenty; you might e.g. wish to take a look at my list of Email Apps for a selection.


1: Depending on the ROM builder, you might not be able to disable the Email app. That would only leave rooted solutions for that final step.

  • As you foresaw, the Disable button was grayed out :). However the problem should be solved now @Izzy. – MickG Dec 4 '14 at 17:38
  • Glad to read! Mind to tell us how you've solved the "grayed-out button"? – Izzy Dec 4 '14 at 19:55
  • I didn't :). As long as it doesn't annoy me, it can stay there, since I have enough memory to not care about it :). I won't take the trouble of rooting just for that. – MickG Dec 4 '14 at 20:15
  • Yepp, that explains :) Still, it's not only RAM. See my comment on Trish's answer: at least the "Exchange component" polls all 60s even with no account configured (noticed that on a freshly flashed device). That might wake-up your Droid and eat some juice, even if little. But again, if you've got no trouble with your "battery uptime", that won't bother you either ;) – Izzy Dec 4 '14 at 20:44
  • And yet another grayed-out button for "Exchange Services" :). It is really astonishing how much stuff I can't do :). – MickG Dec 4 '14 at 21:12
1

Turn off notifications: (this is the same for all apps) Settings >> Apps. Slide to the "All" section and scroll down until you find "Email". Uncheck the box for "Show notifications". You should probably do the same for Exchange Services, which has the same icon.

Remove account from Email app: Settings > Scroll down to the Accounts and tap on Email. Tap the account you want to remove. Tap on the menu button on the upper right (three vertical square) and pick "Remove Account".

  • Good points, Trush! (+1 from me) To fully get rid of that crazy app, see my answer – and optionally apply the same steps to the "Exchange" app (which polls all 60s in the background even with no account configured and the Email app disabled). – Izzy Dec 4 '14 at 17:18
  • @TrishLing the box is grayed out, and I see no "Email" under "Accounts". – MickG Dec 4 '14 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.