Sometimes I've noticed that the Smart Lock - Trusted Face feature doesn't work, no matter what the lighting or the position of my face relative to the phone.

I thought that an "Improve face matching" should do the trick, but when I go to do that, I get this:

Android Lollipop - Improve face matching
Click for full size

Usually a restart fixes things, but this isn't a really good solution. The camera app works normally even when this happens. Has someone found a way to fix this somehow, or should I just wait for the next update from Google?

  • 1
    There is a possibility that there is an app that is still running and using the camera, and hasn't released the resource (resource leak). You probably need to check 3rd-party apps that use camera and make sure they are closed properly. – Andrew T. Dec 5 '14 at 12:19
  • I thought of that, but since the Google camera app, Instagram etc. work normally, I don't think that's the case. – Rick Sanchez Dec 5 '14 at 12:22
  • How did you upgrade to 5.0, through OTA? If yes, did you do it after a factory reset? – Vishnu Prasad Kallummel Dec 17 '14 at 8:01
  • @VishnuPrasadKallummel Yes, through OTA. No, no factory reset just prior to updating, neither after. – Rick Sanchez Dec 17 '14 at 8:51
  • Ok, I think a factory reset would do the trick, as I have 5.0.1 and the face unlock is working fine. By the way, how are you getting the battery percentage on the battery icon? – Vishnu Prasad Kallummel Dec 17 '14 at 9:03

I believe that this is an issue with the Smart Lock app itself. When I enabled the face unlock I started getting this error. The camera ceases to work after some time, when I notice that the smart lock icon just blinks on the lock screen (which shows a failed attempt to access camera). Then neither the camera app works nor can I access the camera via Smart Lock settings. I started having this issue whenever I enabled face recognition and I stopped having this issue altogether when I disabled the said feature.

It's a shame that despite being an extremely efficient and fast feature, this causes such a problem that it needs to be disabled.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.