2

I have three Google accounts registered to my Android: my main, personal account (let's call it account A), and two volunteer community accounts whose emails I manage (call them accounts B and C).

When I first got the phone, I registered with my account A and later added accounts B and C, so that my primary account is account A.

The problem is that since the upgrade from Android 4.4.4 to Android 5.0, one of my apps has lost its license.

When I try to restore the license, I realise that the app is now registered to account B instead of account A (it shows the email address for account B instead of account A).

Why is it registered to the wrong account? More importantly, how can I fix this?

If possible, I'd prefer not to uninstall and reinstall the app, because I will lose all of my data for that app. But, I'll do it if I have to.

I am using an unrooted Nexus 5, fully updated, Android 5.0.

  • 1
    This sounds like something you'll have to talk to Google Play support about. – Dan Hulme Dec 5 '14 at 13:02
  • As you've not mentioned the app name and some details it is wise to clear data of the app in Settings>Apps>App_Name>Clear data and start fresh. – MANI Dec 5 '14 at 15:59
2

I tried various actions, including clearing all data, and uninstalling and reinstalling the app. None of them worked.

Eventually, I removed accounts B and C, uninstalled the app again, restarted the phone, and reinstalled the app.

This worked. The licence was automatically restored.

What's more, Google restored the app's data — admittedly, from a couple of weeks back before the upgrade to 5.0, but still it meant that I lost little.

I'm going to leave accounts B and C off the phone for a while to see what happens.

I think that I should report this fault to Google.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.