0

I have a 3 week old Sony Xperia Z3 Compact (D5833). However, it suddenly turned off and refused to charge.

The phone was at ~10% charge before I plugged it in using the cable and adapter that came with the phone. I didn't notice that the charger light didn't light up because I was busy. Half an hour later, I noticed, and the phone refused to power on and also was unable to be charged.

I've attempted to follow the FAQs located on the Sony Support website: (Main Page --> Z3 Compact --> Troubleshoot --> I cannot power on my device) and (Main Page --> Z3 Compact --> Troubleshoot --> The phone doesn't seem to charge) but to no avail.

Is there anyone out there who can help?

Thanks in advance.

1

Sounds like a loose connection and/or hardware issue.

If you fiddle about with the cable in the port and the light comes on, it could indicate that the cable is potentially faulty, else, if it's only around three weeks old, can you not send it back and get a replacement under faulty/warranty terms?

  • Don't think its a hardware issue; tried fiddling it about and around already. Nothing goes. On the other hand, I've sent it to servicing, now's just the wait. – sysmauys Dec 8 '14 at 13:04
  • It's unlikely that it's a hardware issue, you're right. It's just a possibility as I've have a gadget with a dead USB port before, and I guess the same could apply here. Good luck with the servicing, let me know how it goes! – Alfie J. Palmer Dec 8 '14 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.