1

I am using Android 4.2 Jelly Bean stock Messaging App and the get "message not sent" error whenever I use my contact to send the message. I noticed that the Messaging App might not be using the full 10 digit number to send the text/sms. If I manually enter the full number, e.g., 155551234567 then the message is sent successfully. But if I use the contact then it only shows in the top display that 123-4567 number and then it will fail to send any text/sms.

I am wondering if that is problem and if so how can I set the Messaging App to use the full phone number? I did not find any setting for this anywhere so far.

Thank you for any help.

1

I presume you're talking about US numbers? If you haven't tried including a + at the start of numbers saved in your contacts that could be worth doing. +1 555 123 4567 is the international format and may help other apps know where to send your message/call.

  • Thanks for your reply. I replied early but don't see it here. So am doing again. I already have full phone numbers. – sgw Dec 11 '14 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.