Last days I have strange behaviour:

No incoming/outgoing sound during calls via mobile network. After reboot a couple of calls work find and then sound just vanishes.

Viber/skype calls are working just fine.

No external or suspicious applications were installed (actually no new applications were installed for the last months)

dmesg shows nothing related to audio system.

How I can fix the issue? What information I should dig in my phone?

I've Nexus 4 with cyanogenmod (20141205-nightly-mako) [actually before was 20141105-nightly-make and this thing started after almost a month of usage, then I tried to update, but it didn't help].

  • 1
    Cyanogenmod nightly builds are not suitable for everyday use. If you use them, you should expect behaviour like this, and even worse bugs.
    – Dan Hulme
    Dec 7, 2014 at 16:57
  • Well, but it worked before for about a month
    – rush
    Dec 7, 2014 at 17:10
  • If bugs always manifested themselves right away there wouldn't be so many of them.
    – Dan Hulme
    Dec 7, 2014 at 17:48
  • Yes, it may have worked, but they are called nightlies for a reason. It is the compiled source code built in to a new package, every night. I am a software engineer for my day job. We introduce sometimes hundreds of new bugs, with just one feature change. We then have to go through and fix those bugs. But, the priority of them differs, and if we are in "feature" mode, bugs wait until all the features are complete, then we address the bugs. If you don't want bugs, use the stable builds. Jan 5, 2015 at 1:44
  • I'm not against bugs. This was just a question to get some directions to dig and find the root of such behaviour. And it's great that somebody ere is able to help me. Thank you for your answer and comments!
    – rush
    Jan 9, 2015 at 22:29

3 Answers 3


There seems to be a pretty bad bug that affects Cyanogenmod right now


A workaround provided in the thread:

from a root terminal (adb root/adb shell or terminal emulator/su)

pm disable com.google.android.gms/com.google.android.gms.checkin.CheckinService

  • +0.5 for linking to the issue, and +0.5 for your name, so 1 upvote for you :) Jan 5, 2015 at 1:45
  • 2
    +1 for linking to an issue (that was affecting "stable" milestone builds) rather than just condemning someone for using nightlies. (I personally resolved it by upgrading to lollipop factory image and was relieved that it wasn't just my phones hardware crapping out)
    – Nick Bisby
    Jan 5, 2015 at 21:37

This Problem usually comes with 250MB plus version of google Apps package. If the problem persists, try installing nano version of arm based GApps. hope it will solve the issue.


A friend of mine who also faced the same problem and finally resolved the issue for me. The phone thinks earphones are plugged in due to which ear piece doesn't work. So take a pin and clean the earphone jack. Should resolve your issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .