I have an old Nokia 6300 (2008-era) phone and an Amazon Kindle Fire HD (2012 model) rooted with CyanogenMod on Android KitKat.

The Kindle does everything I want it to do and I see no reason to carry around a smartphone as I have no need for one (yes, this is coming from someone who owned a Samsung Galaxy S3 for two years!).

I have connected the Nokia to my Kindle via bluetooth and have noticed the 'connect to this device for internet-access' option:

enter image description here

Over on the Nokia the E symbol is displayed within a box meaning that the device is connected to the internet; when I toggle the 'Internet Access' option on my Kindle off, the Nokia phone is no longer connected to the internet (the box around the E disappears).

The Kindle is certainly telling the phone that it wants to use it for internet access, but however Chrome on the Kindle is telling me that it doesn't have an internet connection.

I've read on various websites that Bluetooth DUN and PAN is disabled on KitKat because it's buggy and Google haven't fixed it yet. Is this true?

I've also tried various bluetooth DUN apps to try and get this to work and bluetooth DUN simply tells me 'this device is not supported' and the other doesn't do anything.

Is it possible at all to access the internet vi

  • Your phone probaly use bluetooth/DUN, in that case you need to get the connection parameter from your mobile phone provider. An another way is to tether a PC with linux/KDE installed on it to your Nokia phone (for using the phone as an internet acess to the PC). A configuration wizard will appear for asking you to pick a provider and will fill the parameters for you on the PC. Then if you look at the network configuration you will be able to copy them to your Kindle. Commented Mar 7, 2015 at 18:14

2 Answers 2


According to xerox89 at XDA-Developers:

I wont say 100% imposible . But its 90% NO . Try to get a smartphone to tether . A galaxy Y or xperia mini would be cheap option .



  • Bluetooth Stack on Phones/Tablets is incomplete.


  • New rom w/better kernel
  • better kernel
  • Xposed framework + Bluetooth tether
  • the only sure, cure is root + debootstrap-chroot (linux installer) Then you use Ubuntu desktop to share it (pending you bind the bluetooth hardware.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .