2

Few days ago i noticed that the clock on my phone was 4 min earlier than "real" time. I thus moved to "parameters > date & time" to check that automatic was "on" and indeed it was "on". I then unchecked/rechecked the box and every get back to "real" time ... but only for a few seconds ... indeed just a few seconds later the clock suddenly shifted 4 min earlier!

I tried many things before finally discovering that if I turn off "data" connection, the clock remains at correct "real" time. So it is probably an application that for unknown reason is synchronizing to some server and then modifies the clock.

I have a HTC desire - Android 2.2.2 and I have installed no particular application that can make me suspicious to create such time shift (nor i tried to root my phone to any custom ROM).

Any idea for which application could do this or anyone else having same issue ?

3

Try disabling network time and set the clock manually. Network time relies on your mobile operator setting their clocks correctly, while it is usually a good bet, some misconfiguration on their side could mean that their clock is returning incorrect time. Another possibility is an issue in the database of time offsets in the device (this controls corrections for leap second, etc).

Try checking your time with http://time.is/.

  • Thanks for your reply. The network time provided by my operator on gsm/cdma signal is in line with many other clocks (including the link you provided). It is only when I activate "data connection" that for some reason it shifts 4min earlier. I will try to spy wifi to find which connections are made. Maybe some app/service is connecting to a NTP server having incorrect timestamp. – CitizenInsane Dec 11 '14 at 7:16
  • NB: The application installed on my phone are so few and so basic (gmail/play/street/youtube) that it's anyhow hard to suspect them ... maybe a service ... :/ – CitizenInsane Dec 11 '14 at 7:25
0

Some say they have an NTP server host-name entry in their GPS config, the file seems generally to be /etc/gps.conf. You may need to be rooted to access this file, while it seems they are few chances that GPS settings offer to set-up that parameter on Froyo. TIP : You could verify that theory if that problem occurs only when both GPS and DATA (or WIFI capable of routing NTP) are activated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.