I have a Chinese Tablet that was working till last night. I did a factory reset and now it is stuck in small Android logo. I have tried all key combinations to enter into recovery with no success. Please help. Do let me know what information can I provide about the tablet.

System (Android 4.0.4)
Model- L26
Manufacturer - unknown
Device - crane-a088
Product - crane_a088
Brand softwinners
Android Version - 4.0.4 (Ice Cream Sandwich)
API Level - 15
Build ID - IMM76D
Fingerprint - softwinners/crane_a088/crane-a088:4.0.4/IMM76D/20120924:eng/test-keys
Display (800x432)

Processor (ARMv7)
Processor - ARMv7 Processor rev 2 (v7l)
Cores - 1
Max Frequency - 1200 Mhz
Instruction Sets - armeabi v7a, armeabi
SIMD Instructions - NEON

Memory (306 MB)
System RAM - 306 MB
JVM Max Memory - 48 MB

Internal Storage - 639 MB
External Storage - 935 MB

Back Camera - (1.9 megapixel)
Front Camera - (0.3 megapixel)

Sensors (2)
MMA 3-axis Accelerometer
Vendor - Freescale Semiconductor Inc.
Broncho 2-axis Orientation
Vendor - Topwise 3G Inc.

OpenGL 1.X (Mali-400 MP)
Renderer - Mali-400 MP
Version - OpenGL ES-CM 1.1
Vendor - ARM

OpenGL 2.0 (Mali-400 MP)
Renderer - Mali-400 MP
Version OpenGL ES 2.0
Vendor - ARM
GLSL Version - OpenGL ES GLSL ES 1.00

Features (20)
OpenGL 2.0
Android Hardware

Android Software

Model number
Android version
Baseband version
Kernel version
lihongling@lihongling-desktop #30
Mon Sep 24 19.53.13 CST 2012
Build number

2 Answers 2


If it is stuck in bootloop, I suspect corruption in /system. You should either reinstall the stock ROM or install a custom one. The first thing you will need is a custom recovery. According to this post by flowish at XDA-Developers, you can do this by follwing these steps:

  • Download the recovery (recommended latest build)
  • extract and put to your /sdcard
  • open terminal applications (like better terminal emulator) ,or you can use from adb shell and type :

    $ su
    # cd /mnt/sdcard
    # sh install-recovery.sh
    # sh reboot-recovery.sh

Here is the button configuration of the recovery:

Power button : Select

Volume (+) : Up

Volume (-) : Down

After doing that, install a new ROM from the recovery. Here is a custom ROM (from a post by nizar07 at androidtablets.net) that you can install from recovery.

  • Thank you for your reply. It is not stuck in boot loop. When I start the tablet, it shows a small android icon at the center of the tab and freezes there. It does not boot, it just stays there until I press and hold the power button to switch it off.......... When I connect the tablet to my computer with the usb cable, the computer does not recoginze it, neither does it ask for any drivers............ Power button + VolUp + VolDown button does not boot it to the recovery......... Now I am thinking why did I do a factory reset :( Can you advice what do I do next? Commented Dec 11, 2014 at 6:34
  • Where did you perform the factory reset from? The settings app?
    – LyricWulf
    Commented Dec 11, 2014 at 23:34
  • Yes.. from Settings -> Reset -> factory and ever since it is not booting and halts on the small android icon. If I connect it to the computer, it does not even detect the tablet and does not ask for drivers. Commented Dec 12, 2014 at 4:18
  • When you connect it to the computer, does it charge? If not, does it charge from AC? Is there any way for you to know that it is charging?
    – LyricWulf
    Commented Dec 12, 2014 at 6:05
  • when i connect it to computer or AC power socket, the screen comes up with the small android icon. i dont know whether it is getting charged or not. Earlier a small blue LED light use to appear indicating charging but now it is not. If it is not connected to computer or AC, I can power it ON by pressing the power button but it halts at the small android icon that means it is charged. Right?........... I cannot even find a key combination to put it into recovery. i tried lot of combinations. The physical buttons on the tab are: Power, VolUp, VolDown and Back button at the bottom center. Commented Dec 12, 2014 at 6:35

I dont know what happened but surprisingly the tablet booted on its own. I did not do anything new. It is showing in Device manager as Alcatel ADB Android Device and I was able to see the memory card contents in My Computer too. Battery level was 74%, battery charging blue LED came back on, phew!
The only negative thing I saw was that it gave a message on Root Checked app that device is performing very slow. RootChecker said that the device does not have root permission.

Now first thing what I wanted to do was... rooting the device. Here are the steps what I followed:

1. I saw your answer but I dont know terminal applications or adb shell so I configured Play Store and downloaded ClockworkMod ROM Manager - When I tried to install the recovery, it said, recovery for L26 device is not available

2. I then downloaded an utility from srsroot.com because my tablet was listed in the supported page ( http://www.srsroot.com/supported as unknown - L26 - Ubuntu-L26-B-20121016 - 4.0.4 ). There were few buttons Root Device (all methods), Root Device (Smartroot), Reset User Lock, Reset Gesture Lock, Read Gesture Lock, Reset Gmail, Wipe All Data, Reboot Device, Reboot Recovery - To be on the safer side, before rooting, I thought let me check if srsroot utility restarts the device, so I clicked Reboot Device and it restarted.

Refreshing moment came to an end. Now I am back to the same issue.... SRSroot utility rebooted my tablet but again it is getting stuck at the small android icon :(
Now do I need to wait for the magical moment to happen again or is there anything I can do?

Thank you for looking into my issue...

  • Do you have an external SD card? I am not sure if you would be able to reproduce a boot, but put the ROM that I posted in my original answer onto the root directory on your external SD card. You should be able to boot into recovery and flash it from recovery. At least we know that your tablet is not bricked.
    – LyricWulf
    Commented Dec 15, 2014 at 1:43
  • reproducing a boot is a problem... I can flash the rom once it goes to recovery. It does not go to recovery mode :( Commented Dec 15, 2014 at 3:39
  • Honestly, all we can do is hope that you can "magically" get it to boot again.
    – LyricWulf
    Commented Dec 15, 2014 at 4:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .