1

Yesterday, I was exploring my phone's system files and I accidentally renamed apk file of launcher when I was exploring /system/app folder. It renamed to "Launcher2.ap" but I absolutely know it's original name is "Launcher2.apk", so I noticed that and I renamed it back to "Launcher2.apk" and it was running normally. But today, I can't get any screen after boot (but it's booted normally) and there is no notification bar, no back/home/menu buttons and no errors have shown. I googled all solutions for this malfunction (including this website) and every solution says "you can fix this via adb" but I can't open USB debugging mode, because of blank screen. I also tried "wipe all cache and data" in boot recovery mode and tried to install a new launcher via Google Play's Website but the result is same: blank screen. What can I do for this error? Sorry for my english.

Note: The phone is rooted and it is automatically connects to wireless router (am I lucky?) and sometimes the "back/home/menu" bar and notification bar is flashing (~0.3sec) for once and then it goes blank screen again.

Thanks for any idea/help.

  • 2
    What else did you rename or erase from your system? Your going to have to reflash your ROM. Try a dirty flash - don't wipe data or system that way info(pics/music/app data) stays intact. If that doesn't work then a clean installation is required. Before messing with the system ALWAYS make a nandroid/backup, so you can restore if issues arise – HasH_BrowN Dec 14 '14 at 19:33
  • @HasH_BrowN but there are no sections/options for "rom (Install from SD card, etc.)" and "backup/nandroid". There are 3 option: Wipe data, Wipe cache and Reboot. Am I in wrong place or what else can I do? – BSTech Dec 14 '14 at 19:52
  • You will want to be in recovery. Have you installed a custom recovery (TWRP, CWM, or other)? If not, you should install one. You don't say which device your on, so I can't tell you the steps to enter recovery. – HasH_BrowN Dec 14 '14 at 20:10
  • @HasH_BrowN No, I haven't a custom recovery tool and my device is General Mobile E-Tab 4 (runs Android 4.2.2). Also I am really sorry for "phone" word, it is tablet, not a phone. – BSTech Dec 14 '14 at 20:16
  • This by chance isn't a Ministry of Education tablet (F@ith Project)? – HasH_BrowN Dec 14 '14 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.