5

My device is already encrypted. It is not rooted. Note 2 GT-N7100.

I made an attempt to root it earlier a few months back and it tripped the KNOX counter and void the warranty. But it didn't root the device. The SuperSu would crash and it won't allow to apply the update from the play store.

Now I am AGAIN trying to root it and install TWRP recovery, using ODIN 3.9. It just restarts and when I try to boot into the bootloader to check its the same Samsung recovery, no TWRP.

P.S: ODIN shows the "PASS" successfully and has all the indications that the TWRP has been installed.

migrated from stackoverflow.com Dec 15 '14 at 2:14

This question came from our site for professional and enthusiast programmers.

5

In short: Yes, you can root an encrypted device, because "encryption" only encrypts /data and not /system.

Are you sure you are using the correct settings in ODIN for your device and following all directions completely on whichever tutorial you are following? Please cross-reference your tutorial with the XDA Guide (highly recommended that you follow this guide; I can post the instructions here for permanent refernce upon request).

  • Yes I did use the correct settings, but somehow it didn't work. Next thing I did was to try CFautoroot, and it worked!! Don't know how but it did. I guess there must be an issue in the image. – user3055262 Dec 15 '14 at 14:51
  • Maybe it was just a corruption in one of your downloads. I'm glad you could get it resolved! – LyricWulf Dec 15 '14 at 15:02
1

I could successfully root my Moto G3 (2015) encrypted device using the latest twrp version.

I used version 3.0.2.r01. Tried first with 2.8.7-r5 and it didn't work.

http://forum.xda-developers.com/2015-moto-g/orig-development/twrp-twrp-moto-g-2015-t3170537

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.