3

I posted this in stack overflow, but I figured it would be more relevant here.

When I open the DDMS, it shows the device there.

shows the device is there

However, when I try to run my program, Eclipse opens the Android Device chooser.
The Android Device Chooser has nothing under it. picture of the error I'm running it on a mac. I've tried installing the drivers for the phone. I've enabled downloading from unknown sources and downloading from USB.

Adb confirms that it is there too.

The emulator runs fine.

Don't know if this will help or not, but on the phone, there are two notifications. "Connected as a media device" and "USB debugging connected" That should be normal?

The minimum API level is set to 8, so I don't think it's an API level problem.

I've searched everywhere and I can't figure out the reason.

2

It seems to be a layout bug.

Drag one of the column headers in the device chooser where the device should be and change the column width and it magically appears!

enter image description here

You can also double click the device's row even when it's hidden, so you don't have to resize the column each time.

Source: stackoverflow:

1
  • on my android studio does not work
    – toha
    Aug 12 '16 at 23:16
1

Try disabling "Connected as a media device" (unmounting storage). On your device, you should be able to select the notification and then select an option like "Charge only" to disable the mount. You may have to go to Apps > Settings > Storage > Menu (button) > USB computer connection to change the setting.

1
  • on my android studio does not work
    – toha
    Aug 12 '16 at 23:16
0

Have you enabled developer options in your mobile? If yes, then navigate to Settings > Developer Options(turn it on) >and select(or check depending on your phone) USB debugging this should work

1
  • on my android studio does not work
    – toha
    Aug 12 '16 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.