A little while ago I clicked a link in Firefox that led to an mp3. My thumb slipped and I tapped "always open with", ES Music Player when what I really wanted was to just save it. Now every mp3 link spawns ES Music Player, and that's not what I want.

How do I reset Firefox so that it asks me again for these kinds of links?

I've already done to "2 finger Top Swipe: Settings: Apps: Firefox: Launch by default: Clear".

ES Music Player isn't in the settings app list at all, so I couldn't clear that.

ES File Explorer, which is the parent app for the music player shows "No defaults set" in Android settings. Internally it has it's own "Settings: Cleanup settings: Clear defaults", but that had no apparent effect either.

  • My "wonder list" has a section Manage Default Apps. Maybe one of those is able to find ES Music Player to revoke its default? I'd give Default App Manager a try, as its screenshots indicate it doesn't only work on a "per app" base, but also "per category" – and thus you might be able to locate "MP3 playing" there. Not tested myself, hence no answer (yet).
    – Izzy
    Dec 16, 2014 at 10:16

3 Answers 3


This is the setting of Firefox on Android and not android itself Follow these steps:

  1. Open Firefox and in address bar type "about:config"
  2. Search For "browser.download.preferred.audio/mpeg" (just "mpeg" does the same)
  3. Press on the reset button
  4. From now on, if you download any mp3 file in Firefox, it asks for available apps capable of playing the file. You can again choose once or set it as default.
  • +1 utter madness that there's no way to access this list in settings and you have to use. about:config Mar 25, 2017 at 16:40

I'm unsure about Lollipop (as a KitKat user), but I'm guessing you've already checked every tab in the Apps menu? Otherwise, does ES File Explorer (or ES Music Player) have a settings menu that would allow you to change the way it opens files?

If not, I'd recommend uninstalling ES File Explorer and then reinstalling it.

  • I've looked everywhere for setting inside ES File Explorer for this, but no go. Coming from desktop world, I expected this to be a Firefox setting, like it is there. Beginning to sound like I need to ask the ES developer instead. Dec 16, 2014 at 7:56

Well, the simple way to do that is by heading over to the setting>application manager>tap over the firefox (clear its defaults stored) also search for "ES Music Player" over application manager tap over it (Clear the app defaults). Now you try what you are doing previously this time it will ask for the application to select opening the file !

  • As posted, I already tried that. Dec 16, 2014 at 7:02
  • 1
    Swipe over the left to All in the Application manager and look out for ES Music player, its should be their ! Dec 16, 2014 at 7:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .