0

I recently updated my Nexus 5 to Lollipop. The problem is that when I am on a mobile network, I can ONLY open HTTPS websites. All the HTTP websites appear as a blank white page. When I am on WiFi, everything is fine. I am located in India, if that matters.

Any ideas why this might be happening?

Edit: Same is happening on another phone, which is Nexus 4. I have tried different browsers, and the results are the same.

Edit2: I used remote debugging on Android with Chrome.

Here is the response to http://stackoverflow.com

Remote Address:198.252.206.140:80
Request URL:http://stackoverflow.com/
Request Method:GET
Status Code:504 Gateway Time-out
Request Headers
Accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Accept-Encoding:gzip, deflate, sdch
Accept-Language:en-GB,en-US;q=0.8,en;q=0.6
Connection:keep-alive
Cookie:prov=5a7a2230-005c-463e-afda-63c634dd4a73; __qca=P0-84958589475-140584875859968; _ga=GA1.2.749475574.1948596847
Host:stackoverflow.com
User-Agent:Mozilla/5.0 (Linux; Android 5.0; Nexus 5 Build/LRX21O) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.59 Mobile Safari/537.36
Response Headers
Connection:keep-alive
Content-Length:0
Date:Wed, 17 Dec 2014 03:42:50 GMT
Server:WebProxy/6.0

When I try to open https://stackoverflow.com, here is what I get:

Remote Address:198.252.206.140:443
Request URL:https://stackoverflow.com/
Request Method:GET
Status Code:200 OK
Request Headers
Accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Accept-Encoding:gzip, deflate, sdch
Accept-Language:en-GB,en-US;q=0.8,en;q=0.6
Connection:keep-alive
Cookie:prov=5a7a2230-005c-463e-afda-63c634dd4a73; __qca=P0-84958589475-140584875859968; _ga=GA1.2.749475574.1948596847
Host:stackoverflow.com
User-Agent:Mozilla/5.0 (Linux; Android 5.0; Nexus 5 Build/LRX21O) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.59 Mobile Safari/537.36
Response Headers
Cache-Control:public, max-age=39
Content-Encoding:gzip
Content-Length:19401
Content-Type:text/html; charset=utf-8
Date:Wed, 17 Dec 2014 03:43:21 GMT
Expires:Wed, 17 Dec 2014 03:44:01 GMT
Last-Modified:Wed, 17 Dec 2014 03:43:01 GMT
Vary:*
X-Frame-Options:SAMEORIGIN

Obviously, the HTTP request is getting timed out. I am on the Vodafone India network. Any help?

-1

Changing the APN settings to "VodafoneMobileConnect" fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.