6

I updated my Moto G (XT1032) to the new Lollipop (5.0.1, I think). I left the phone plugged in to let it download and install, and when I came back to it after about a half hour, the phone was displaying the screen with 'Google' and an unlocked padlock on it. I left it for another 20 minutes or so, but it stayed on the same screen. I couldn't power it off at all, every time I tried to, the screen would turn off, but then come back on and vibrated once, only to go back to the padlock.

I ended up going through the Flashboot menu and cleared the Cache Partition, but that made no difference. Also tried a factory reset, but that seemed to make no difference. Currently, the phone is still sitting at the padlock screen.

The Flashboot menu says that the phone is unlocked, but I have no memory of doing this. Maybe it's something to do with the update failing?

Just wondering if anyone has some advice on how to proceed with this.

5

Well, there are two ways to fix this one out:

Requirements:

  1. You need to have a custom recovery (CWM/TWRP) installed
  2. You are going to require Stock firmware zip file for Moto G XT1028, XT1031, XT1032, XT1033 and XT1034 which can be downloaded over here
  3. ADB and Fastboot

Method 1:

  1. Boot your phone into custom recovery mode. Recovery will have adb on by default, so leave recovery as it is.
  2. Connect your phone to your PC and open command prompt and issue the command: cd directory-with-adb.exe-and-fastboot.exe
  3. Now, issue the command: adb devices. If Moto G drivers have installed properly, the phone will show up. If not, get it over here and install it over your device
  4. Now, from recovery wipe /data and media
  5. Open command prompt and execute: adb push rom.zip /sdcard/rom.zip It will take some time to install the ROM. If you face a not working SIM or WiFi, extract the downloaded ROM zip file and navigate to extracted firmware folder using cmd and issue:

fastboot flash modem NON-HLOS.bin

fastboot erase modemst1

fastboot erase modemst2

fastboot flash fsg fsg.mbn

Method 2:

  1. Extract the downloaded firmware file to a folder.
  2. Download and extract mfastboot and copy its content to the same folder where the extracted firmware files.
  3. Reboot your Moto G into the Bootloader Mode. To do so, turn off your phone and then press and hold the Volume (-) and Power buttons simultaneously for a few seconds.
  4. Connect your phone to your PC via USB cable.
  5. Now, launch a command window from inside the firmware folder (click shift key, right click and select open command window here option).
  6. In the command window, issue the following commands one by one:

mfastboot flash boot boot.img

mfastboot flash recovery recovery.img

mfastboot flash system system.img_sparsechunk.0

mfastboot flash system system.img_sparsechunk.1

mfastboot flash system system.img_sparsechunk.2

mfastboot flash modem NON-HLOS.bin

mfastboot erase modemst1

mfastboot erase modemst2

mfastboot flash fsg fsg.mbn

mfastboot erase cache

mfastboot erase userdata

mfastboot reboot

Note: If firmware includes four system.img_sparsechunk or you do not want to erase the userdata, you can modify the command. You have now successfully installed a fresh ROM on your Moto G and the phone the phone should work as usual.

Also, depending on which version you are going to and from, you may need to try using the standard fastboot rather than mfastboot.

Source: [GUIDE] Restore softbricked phone after Lollipop update over on the XDA Developers forum, specifically post 1 and post 14.

  • I couldn't get your procedure working with mfastboot, but I did get it to work with the standard fastboot which is part of Minimal ADB and Fastboot – Mark Booth May 17 '15 at 1:50

protected by Community Jul 15 '15 at 15:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.