0

Suddenly Google Play stopped working and now it is always asking me to provide an existing account or that i create a new one. When i try to use my existing one, it tells me that that account is already installed on Android and it returns back to the "Provide existing or new account" screen. When i remove that account from my device, it allows me to provide my existing account, we walk through the screens, i skip the credit card screen, and afterwards Play does not start. When i start Play again, it again asks me for an account...

Using the same account within the email app works without problems, syncing contacs, calendar etc. works as well without any issue.

How can i find out whats going wrong with Play now after it worked nicely since i have purchased the device?

  • Have you tried going to (this may vary slightly depending on device) System>Applications>Play Store and tried clearing the cache and data? Worth a go. You can also get the latest Google Store (and legacy versions) on Android Police. They are signed by Google and I've been using them for years (no affiliation). – RossC Dec 18 '14 at 14:56
  • yes, i also cleared the cache on Google Play without success. Android Police? never heared about it. Is this a replacement for Google Play? – Joysn Dec 19 '14 at 11:00
  • No it's just androidpolice.com they carry google apps apk files which you can install, including the play store! – RossC Dec 19 '14 at 13:40
  • Did you force stop the apps before clearing data/cache? Also do google framework as well. It might take a few minutes or so for google to sync its data for play store to work again. There shouldn't be any issues then. – HasH_BrowN Dec 22 '14 at 1:02
  • if i force to stop every google app like play services, play store and google framework, and then clear those caches, and re-run Google Play, it asks me to connect using an existing or new account. When i provide an existing Gmail account (which i use as email on hte devices as well), right after waiting some moments and after confirming the Google usage notice checkbox, Google Play services terminate with a small popup telling me this, and a few seconds later the device tells me that "com.google.process.gapps" has terminated. – Joysn Dec 23 '14 at 14:16
0

This worked for me.

go to settings -> apps -> Google play.

Disable the app, uninstall the updates and re-enable it.

0

Try the above methods... If they don't work I would recommend you to flash gapps for your device with proper android version and architecture... This worked out for me. I'm running stock rom and faced the same issues. Also don't forget to wipe cache from recovery

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.