I'm trying to run fastboot oem get_identifier_token on Mac OS X Yosemite but I get stuck on "< waiting for device >":

➜  platform-tools  ./adb devices
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached
FA495WM04764    device

➜  platform-tools  sudo ./fastboot oem get_identifier_token
< waiting for device >
  • I have enabled USB debugging
  • I have tried both sudo and no sudo on fastboot
  • I have tried restarting, changing USB ports (although they are just two on my Mac Book Pro Mid-2012).
  • The SDK is the latest one, downloaded today from http://developer.android.com/ together with Android Studio
  • I also tried downloading just fastboot-mac from HTC dev site, same happens there.

Any ideas?

  • 2
    Are you sure the device connected is booted into fastboot mode? To me that looks like it's booted "normally".
    – Izzy
    Commented Dec 18, 2014 at 12:14
  • 1
    As Izzy alludes to, fastboot is a different completely separate boot mode. If adb is recognizing your device then fastboot won't be able to communicate with it, because it is not running on the device's side. Try adb reboot bootloader before issuing the fastboot commands. Commented Dec 18, 2014 at 14:48
  • Guys, that was the issue I realised it a bit after I posted the question. If someone adds the answer, I will accept it for other lost souls.
    – ddinchev
    Commented Dec 19, 2014 at 0:48

1 Answer 1


As others have commented you need to reboot your device in bootloader (fastboot) mode.

Easiest way, is to use the command

adb reboot bootloader

Your device will reboot and will end up in the fastboot mode. Now you can use the fastboot utility.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .