I own a LG G2 D802T. I have rooted it successfully with IORoot but when I try to flash a custom recovery on it, it always fails. I have also tried AutoRec for D802T although it flashes and I am able to enter into TWRP but then phone got stuck at LG Logo and only option left is to flash a kdz through LG Flash Tool again. I have searched for it on several forums but unable to find the answer. Can anyone help me on it as how can I flash TWRP or CWM which work 100%. (Also I have tried several apps from Play Store as well).

  • rooting alone might not be sufficient. Is the bootloader unlocked? I have an LG O4X, and there you only can install a custom recovery after unlocking the bootloader. I'd wonder if that would be different for the G2. – Izzy Dec 18 '14 at 12:17

I had the same problem with my D802T. What you need to do is that before you install recovery, copy the zip file for any rom ( i did cloudyg2 3.3). Then once you boot into recovery, wipe the cache and dalvik cache and then install the zip. Once the installation is successful, the phone will boot into the rom without getting stuck at the LG logo. Once you are into the rom you can switch off the phone and try to use the key combination ( vol down + power keys) to go into recovery. Or else download an app that lets you boot into recovery.

For more info go to this link. Look for my comment on page 2 for more details. Hope it helps

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.