0

I'm trying to add my school Gmail account to my new Nexus 9 tablet. The OS is 5.0.1. The account is a Google Apps account. I've entered another Google Apps account without a problem. After I enter the username in the "Add account" screen, I hit Next. The password screen goes white, with no button or fields.

Does anyone have any idea how to fix this?

1

I ran into this issue after updating to Android 5.0 and reported the issue to Google. I was promptly told "it's a known issue, but no ETA on fix". I ultimately resolved the issue for me, using this process below. I hope it helps you!

I was trying to add an account (from my school) that used web-based authentication for Google apps. After running adb and trying to add the account, I captured the following error when the white screen was displayed:

I/GLSActivity( 5367): [AuthUrlChecker]Untrusted Auth URL: \http://my.pcc.edu/ProcessResponseServlet I/GLSActivity( 5367): [AuthUrlChecker]Untrusted Auth URL: \http://my.pcc.edu/ProcessResponseServlet I/GLSActivity( 5367): [AuthUrlChecker]Untrusted Auth URL: \https://my.pcc.edu/GoogleAltLogin-2.0.7/GoogleRedirect.jsp I/X509Util( 5367): Failed to validate the certificate chain, error: java.security.cert.CertPathValidatorException: Trust anchor for certification path not found.

I visted the url "https://my.pcc.edu/GoogleAltLogin-2.0.7/GoogleRedirect.jsp" in Chrome on my desktop, and noticed that there were no certificate issues (go figure!). I used Chrome to view the certificate trust chain for the website, and compared this to the certificates installed by default on my Android 5.0 device (go to Settings->Security->Installed Certificates->System to get list).

I noticed one certificate that was missing on the Android device, "VeriSign Class 3 Secure Server CA - G3". Google Chrome on the desktop thinks this is trusted, so I exported just this one certificate using Chrome, and saved it in the DER-encoded format with a .cer file extension. Then I copied this to the Android device and imported it into the certificate store (Settings->Security->Install from Storage). After doing this, I was finally able to add my Google apps account that uses web authentication!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.