My problem is exactly the same as in this question: Custom ringtone not working on Nexus 5 since OTA Lollipop

  • I have Nexus 4, never rooted, never jail-breaked
  • after I installed the update to Lollipop, the problem occured
  • now I have already 5.0.1 but the problem still exists


  • I select my custom ringtone on the Sound & notification settings panel and it plays right
  • when someone calls me, only the default system notification sound is played repeatedly

What I already tried:

  • re-uploading the ringtone, using AirDroid (I also uploaded them with AirDroid before the update to Lollipop)
  • clearing cached data (via Settings > Storage > Cached data) and then rebooting
  • checked the directory of the ringtones: it's /sdcard/Ringtones
  • checked the permissions of the ringtones: it's the same as for system-ringtones: -rw-rw---- root
  • I found out, that when I select the ringtone in the contacts-app as a specific ringtone for one person, it works!

Any ideas?

  • possible duplicate of Custom ringtone not working on Nexus 5 since OTA Lollipop
    – bmdixon
    Jan 8, 2015 at 8:49
  • I wrote in my description that the answers in that article didn't work for me. I wanted to write an answer or a comment to that article but I couldn't because I don't have enough reputation points. So the only solution I saw was to open a new thread.
    – nyx
    Jan 9, 2015 at 9:08

2 Answers 2


On my Nexus 4, for ringtones snipped by Ringdroid the following worked: Ringdroid saves to the following folders:
I copy-and-deleted the ringtones from those locations to the following folders:

This left duplicate entries in the Android settings and messaging settings. To fix that I then cleared the Cache Partition from the recovery in the bootloader by the following directions:
Here's a short version:
Power off
All three hard keys for about 10 seconds to enter the bootloader menu
Uses arrow keys to select Recovery Mode and power to activate
Power and Volume Up (to actually get into recovery menu I guess?)
volume to "Wipe Cache Data" and hit power
Return to bootloader

You can now set ringtones and they will actually work.


Over the holidays I found a solution :)

I connected my phone via usb-cable with my computer and used "adb push" to copy my ringtone into the folder /sdcard/Ringtones. This is the same folder that is used by AirDroid for ringtones. And the new ringtone-file (that was added by adb push) had the same permissions (-rw-rw---- root) like the ringtone-files that were put there by AirDroid.

Then I restared my phone (just simple turn off, turn on, no deletion of cache), selected the new ringtone and -- it worked!

I think it has something to do with AirDroid but I can't tell what AirDroid does wrong, because I can't see any differences between the files I put by "adb push" and the files that AirDroid put there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .