0

Have a Verizon 4.4.3 Galaxy S4 using the standard cable. When I connect to the PC, the PC doesn't show it in explorer. The phone doesn't bring up the connection notification. I have enabled/disabled developer options. Re-installed the drivers. Tried different USB ports. In the end all it does is charge. I know this worked before as I have done it before, but this was before many updates ago.

The reason I need this is for debugging an android application I am developing.

Any ideas?

Thanks

  • 1
    Have you tried with different cables? – Cornelius Dec 19 '14 at 20:59
  • I do not have any other cables – Patrick Ryan Dec 19 '14 at 21:17
  • 2
    Buy a different cable – samsung Dec 19 '14 at 22:59
0

Samsung usb cables have a history of being finicky with data connections. I know it personally from trying to root several Galaxy phones over the years. Your best bet is to buy another usb cable. I highly recommend cables from Monoprice as they are cheap and high quality. However to be fair, any good quality cable you can find from another manufacture would be your best bet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.