I have a Tmobile MyTouch 3g. When I connect it via usb to my 64 bit Windows 7 machine, I do not get any option to mount for USB storage as I typically have in the past. I also do not get any option when connected to my Windows XP work machine.

I have tried getting the mytouch to dismount/mount the sd card under settings and then replugging in the phone with no effect. Not sure if there's anything else under settings I could try.

When I look in Windows 7's device manager under USB there's an "Unknown Device" listed. I "uninstalled" this device by right clicking and saying "uninstall". Then I reattached the mytouch 3g and all I got was "unknown device" again.

There appears to be a couple of forum posts on this issue, including here and here but none of them have been helpful. Only the last one seems to accurately 100% describe this problem, but nobody has responded to the post.

How can I fix this? I'm hoping it doesn't involve resetting the phone to factory defaults.

  • Do you have HTC Sync installed? I believe it comes packaged with drivers, so installing it might help even if you don't intend to use it. Also, for what it's worth, I had this problem with a Samsung Captivate I use at work and rebooting the phone mysteriously fixed it. May 13, 2011 at 3:54
  • You haven't switched on USB Debugging mode or anything like that recently have you?
    – GAThrawn
    Jul 12, 2011 at 12:17

2 Answers 2


Try installing the official drivers from the Android SDK.

  • that seems to require either downloading the SDK through eclipse or going through Device Manager to tell the device to update its drivers. I don't think getting the SDK to fix this is reasonable, and what I see in my device manager doesn't line up with what they tell you to do. Unless I'm missing a Windows installer or something.
    – Doug T.
    May 13, 2011 at 1:59
  • 2
    @Doug You don't need to download the entire SDK, and you don't need to use Eclipse. The installer is only 31 MB, most of the SDK is downloaded afterwards optionally. You can choose to have it download only the driver from what I know. May 13, 2011 at 12:54

I too have the same problem with the USB mass storage menu. After unplugging it from usage, I noticed after using the wall charger it doent give that option anymore when I want to copy files from my computer to the phone. The only solution I have came up with is turning your phone off then turning it back on. After that you will have the USB mass storage option back again when plugged into your computer. SO anytime you use the wall charger to charge your phone over night or during the day, you must turn your phone off then on the enable USB mass storage again. (after turning phone back on, do not reconnect the wall charger then to the computer or you will not enable the USB mass storage menu)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .