2

I have a GalaxyNexus running Android 4.2.2

I just want to quickly backup some data files to my PC. I'm pretty sure I've done this many times before, but I guess not on this phone.

I have the Android SDK and tools installed on my PC. I attach the phone by USB I run monitor.bat and go to the File Explorer tab

Now, I can see and explore the file system.

I believe the folders I want to back up (like DCIM and Download) are under /storage/sdcard0 When I run a file explorer app on my phone, I see the folders under this path. However, when I run the File Explorer from my PC I don't see the folders.

Do I have to do something to unmount the folders first before I can access them through USB? Do I have to shut off MTP and put the device in USB storage mode?

What am I missing?

1

Normally you would put the device into storage mode. When the phone is normally booted without storage mode you'll only be able to see internal, then when switched to storage mode you'll see the sdcard as well.

But VerizonWireless says the Galaxy Nexus doesn't come with USB storage mode. According to them you would transfer your data/files to PC across MTP.

So having the external SD card not show in PC explorer, can be bypassed by inserting it into a card reader on the PC. A little inconvenient, but will accomplish your task.

  • When I go to settings->Storage and then pick the menu and then pick "USB Computer connection" my only choices are MTP or PTP. I don't have a "storage mode" option. I looked at the suggestions in forum.xda-developers.com/showthread.php?t=2350542 but none seem to work for me. How do I put my device in Storage mode? – Michael Levy Dec 24 '14 at 4:58
  • Take a look at reddit.com/r/Android/comments/1aqjd0/…. I don't think my phone supports USB Mass Storage as described in this post. They suggest just using MTP which seems fine. – Michael Levy Dec 24 '14 at 5:07
  • Just saw the reddit link. Interesting workaround for the galaxy notes. – HasH_BrowN Dec 24 '14 at 5:32
  • MTP from Windows works, but I see why people in the Reddit thread are complaining. It does not behave like a drive or partition under Windows. I usually use Microsoft RichCopy, but it doesn't look like RichCopy can see the MTP device (it doesn't have a drive letter or UNC path). Windows Explorer can see the file system through MTP and I can get to the DCIM folder, but my file copy hung for no apparent reason and I had to restart it. – Michael Levy Dec 24 '14 at 5:37
  • Nothing ever wants work right ;) Try "teracopy" for PC. Works when copy seems hang. You can also do CRC validation after copy and other things. – HasH_BrowN Dec 24 '14 at 5:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.