0

So I flashed CM11 nightly back in November making sure to perform the boot.img fix and things worked OK. I recently decided to update. I will confess that I updated without fixing the boot.img and soft-bricked the phone. Had to re-flash Philz Touch using odin and eventually re-installed the CM11 .zip.

Now WiFi won't turn on. If I go to the WiFi page in settings it stays stuck on "Turning Wi-Fi on...". I've tried 1223 nightly and the 1217 nightly (the earliest link which works).

Is there a way to find old nightlies? Most of the links on the Exhilarate page are broken. How else can I troubleshoot Wi-Fi?

UPDATE: I installed the most recent available CarbonRom and the problem is not fixed.

UPDATE 2:

Dialling *#*#526#*#* doesn't do anything. When I enter the last * the code vanishes and nothing happens.

UPDATE 3: Relevant log?

[ 01-04 00:14:29.413   680:  844 E/WifiHW   ]
Unable to open connection to supplicant on "/data/system/wpa_supplicant/wlan0": No such file or directory
[ 01-04 00:14:29.924   680:  844 E/WifiMonitor ]
startMonitoring(wlan0) failed!

[ 01-04 00:14:29.924   680:  844 E/WifiStateMachine ]
Failed to setup control channel, restart supplicant

[ 01-04 00:14:32.406   680:  844 E/WifiMonitor ]
startMonitor called with unknown iface=wlan0

2 Answers 2

1

Did a backup of apps using adb.

adb backup -apk -all -f backup.ab

Then booted into Recovery and performed a factory reset. Rebooted and Wi-Fi worked.

Restored apps using

adb restore backup.ab
0

I had the same problem on my Nexus 4 with Android 5.0.1 and I fixed it by removing this folder /data/misc/wifi or the equivalent in your phone and then rebooting. You can try this by booting your phone using a boot insecure image.

$ fastboot boot boot.img
$ adb shell rm -r /data/misc/wifi
$ adb reboot
3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .