0

My phone (Micromax A092) running stock Android 4.3, has recently got factory reset by mistake. Using Photorec, I was able to recover all my files stored in the part of the phone memory, used as an sd card. However, to recover my contacts, I need to access the partitions which I believe, need root access. However, trying to root it is a challenge altogether in itself, as my PC doesn't detect my device in any mode except in "sideloading" mode. I've edited 51...rules, with info from lsusb, but it still has not worked. I run Xubuntu 14.04, and am in desperate need of my contacts. To clarify my earlier statements:-

  • $adb devices returns a blank line
  • $adb {anything else} returns device not found et al.
  • In "fastboot mode", only the Micromax logo is displayed on the screen, and nothing else.
  • My USB Debugging is enabled I've tried using it as USB, PTP, MTP, and in charging mode to see if anything happens, but it has all been in vain.
  • Even fastboot does not detect my device
  • In USB/MTP/PTP, it mounts as usual and I've tried the commands, with the device mounted and unmounted.

Can someone please help me recover my contacts? If not, atleast in rooting my device? Thanks in advance.

1

[Solved] I had to edit my ~/.android/adb_usb.ini file; it was written with something else. I found the vendor id from lsusb and replaced the contents with 0x{vendor id}

0xlc9e

in my case

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.