2

The Problem: I've attempted rooting my Galaxy S3 (unlocked, I9300, recently upgraded to Android 4.3 , and 3.0.31 kernel) through heimdal on Ubuntu Linux by following this guide ( as well as following some of the comments, because I kept getting Android recovery instead of ClockworkMod Recovery ). However , Supersu still tells me I've no su binary there. Now, apparently I have another su binary ( /system/xbin/su ) but not in /system/bin.

I've poked around the forums and what not, but couldn't find anything satisfactory, plus many refer to Windows.

Help me out here, folks, how do I get this binary ? How do get root ?

What solved the problem: Basically, I've caved in, and used Odlin on Windows, with instructions from another source ( which I wish I'd saved ). One thing for sure, the guy on the original link i posted , does something wrong so it doesn't work. Also, the packages he lists for download are missing CF autoroot or CF root, but even if I've downloaded and added those, nothing happened.

Another things I've done is removed heimdall that the original website suggested, and downloaded heimdall from Ubuntu repositories. If you search with apt-cache search heimdall there is only like 3 packages, like 30MB, so just do sudo apt-get install heimdall*.

In conclusion , it's nice there's tons of articles on Android, but some may be misleading or simply click-bait.

  • related: How can I root my Samsung Galaxy S3 – Ryan Conrad Jan 2 '15 at 2:28
  • On SE sites, it's perfectly fine to answer your own question – but answers should be posted as answers, not as part of the question-post. Mind editing that out of your question, and move it to a separate answer? Thanks in advance! – Izzy Jan 2 '15 at 12:29
  • @Izzy Well, I wouldn't say I found definitive answer, rather i simply added small update of what i think went wrong into my question, which is most users see first when opening any question, right? I just rooted the phone again with another package, which is basically what GiantTree below has suggested. But if it's better to post something bellow, let me know and I'll post – Sergiy Kolodyazhnyy Jan 2 '15 at 12:37
  • If you could include the steps you've taken (so others can follow the procedure), I'd definitely recommend that. If it's basically what GiantTree suggested, you could also ask him to include it with his answer – or edit it yourself if the changes are not too heavy. When done, we should remove our (currently 3) comments here for cleanup. – Izzy Jan 2 '15 at 12:41
0

I would suggest you root again eg. with CF-Autoroot. You can find some answers in the FAQ of xda-developers: http://forum.xda-developers.com/showthread.php?t=2148708

If you have CWM-recovery already installed then just boot into it and reboot again. It should tell you that root access is missing and you should fix that by simply accepting the recovery's offer of fixing root for you. Then you just need to update SuperSU and use it to update the su binary.

Even though they advise you to use Odin on Windows using Heimdall should work as well.

  • 1
    Welp, I've basically caved in , and went to use Odlin and another zip package with CF autoroot. Whatever the author on original website that I posted was doing - none of that worked, even newest article about rooting for my I9300 galaxy on Windows. Basically, rooting again worked, so that's why I'm accepting your answer. – Sergiy Kolodyazhnyy Jan 2 '15 at 4:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.